Jump to content
  • 0

Unremovable nested folders


jtc
 Share

Question

I have 4 identical drives, each 3TB, pooled under Drivepool on Windows 10. All pool files are duplicated.

 

There is a "stuck" nested folder structure which is duplicated on two of the drives, and which appears in the Drivepool virtual disk directory (Drive I:, in my case.). The stuck folders cannot be deleted under Windows or within the DrivePool virtual disk.

 

The folder structure is 10 levels deep culminating in "shellext ".  In other words "M:\fixme\T2\T3\T4\....T9\shellext ". I cannot recall how I managed to create this originally, but after shortening all the subfolder names and trying every Windows trick on the Internet, I was unsuccessful at deleting it. There is a space appended to "shellext " that is presumably preventing deletion, and all attempts to rename this file/folder have failed.

 

The one trick that worked was booting a live Linux disk and deleting the duplicated structures on disks M: and J: where I found them. However, after rebooting to Windows, the deleted items are restored after a period of time, and I'm back where I started. When I try to delete the folders directly or in DrivePool, the error message is (and always has been) "Could not find this item."

 

Is DrivePool contributing to this problem, or causing the restoration of the deleted folder structure?  Any ideas on how to fix? The problem isn't fatal, but it is an annoyance.

 

 

.

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Solved (Knock on wood,)

 

Thanks to everyone for the prompt suggestions. For future reference, the list below contains commonly advised methods to delete stuck files when a space has been appended to the file names.

  • Use quotes that enclose the trailing space:  rd "my folder "
  • Same as above, but add a trailing [back]slash: rd "my folder \"
  • Try using <shift>+delete to bypass the recycle bin, as suggested by otispresley
  • Specify the UNC path:  rd "\\.\C:\temp\my folder "
  • Try 8.3 names (if enabled): rd myfold~1
  • Finally, boot a Linux Live CD:  rmdir "/media/blahblah/temp/my folder "

What worked for me:

 

I first uninstalled Dropbox, just in case there was some interaction as Christopher suggested. (I have a vague recollection that the troublesome folders were,in fact, related to a Dropbox incident.)  Next, I launched an administrative command prompt and traversed the PoolPart folder on each of the two drives, one drive containing the original and the other the duplicated copy of the intransigent folders. Finally, after trying the UNC path solution and the Shift-Delete method with no success, I tried the second of the ideas listed above, adding a trailing backslash to the "shellext " folder name that was causing all the trouble. ( RD "shellext \"  )  It worked.  Once done, the remainder of the folder structure was removed with RD /S FIXME, "fixme" being the first-level folder.

 

The errant folders have also disappeared from the DrivePool virtual disk, which did not happen when I had tried a Linux Live CD on my previous attempt.

 

Anyway, thanks again.

Link to comment
Share on other sites

  • 0

StableBit DrivePool shouldn't have an issue with the folder.  But if the underlying file system does, then DrivePool will as well. 

 

That said, it sounds like something is creating this folder automatically.  If the file is in use, it will likely lock the file as well, preventing it from being deleted.

 

A quick check looks like this may be a DropBox related folder, and a common issue. 

Link to comment
Share on other sites

  • 0

I had a similar issue that I wrestled with for months. It turned out that the path was too long for the recycle bin. In the end, it was the very simple <shift>+delete under Windows to skip the recycle bin and permanently delete that did it.

 

***NOTE*** I had tried forcefully taking ownership, changing security permissions, and forcefully deleting, but none of it worked.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...