Jump to content
Covecube Inc.
  • 0

Remove Disk "Access Denied"



I'm using DrivePooler since a couple of years.


Still I run Windows Server Essentinal 2012R2 with DrivePooler "StableBit.DrivePool_2.2.0.727_x64_BETA".


I want to remove a Disk from the Pool to replace it with a bigger one.


The last times I did it, I moved all folders in the hidden DrivePool folder to a temporary folder on the same drive.

This did go well now.

But now I if try to remove the disk from the Pool I get an error Message.

Error removing Drive "Access Denied".

I tried with force but still the same problem.


Can someone tell me what’s wrong?





Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

It looks like you still have applications accessing the pool and are not closing. 


Close anything that is using the pool and then try removing the disks. 



Otherwise, use the "Drive Usage Limiter" balancer, uncheck both "duplicated" and "Unduplicated" on the drive in question.  This will prevent new files from being placed on the drive, and will try to balance the data off of the drive, until it's empty (provided there is enough space on the rest of the disks in the pool). 

Link to post
Share on other sites
  • 0

Hi Chris


I have the same problem with removing a drive from the pool - i think its the sys vol info directory as it flashes up briefly before the error shows


Have tried all three options to remove the drive from the remove "button" - i.e. no checked, one checked and both checked same result


Logs have been uploaded


Drive only has "other" files on it

Link to post
Share on other sites
  • 0

I managed to remove the disk by disconnecting it from the system.

I copied the data over network to the pool.

I also tried to run the Wss.Troubleshoot_1.0.0.169 a couple of time with problems.


The last try was successful and now I have no problems accessing the pool anymore.


But still I don't if it is possible to remove a disk.

Link to post
Share on other sites
  • 0

The removal should complete.  The only reason it wouldn't is if there is a file system error, or ... well, a bug. 


If you're using the latest version, then I'm not sure ...


I've looked at the service logs (text) and it doesn't indicate why. 


It may be worth running "CHKDSK \\?\Volume{31d83938-70f6-43e2-bc03-0c21894a3381} /f" on the system (as this appears to  be the problem drive).   


During removal, we mark the folder in a couple of ways, and that may be where it's erroring out on. 



Additionally, there is the dpcmd's "ignore-poolpart" command. That will IMMEDIATELY drop the drive from the pool.  This DOES NOT remove the data on the drive, and causes the disk to show up as "missing" in the pool. 


You should be able to run "dpcmd ignore-poolpart X: PoolPart.e95092e8-fbdf-4701-9e2e-33d190be8786" (where "x:" is the pool drive letter) to do this. 


You'd need to then manually move the contents of the 'PoolPart" folder from that drive back into the pool, though. 








Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...