Jump to content
Covecube Inc.
  • 0
Thanatos0042

Running the Scanner crashes entire server

Question

Greetings,

 

I started a ticket on this, but I thought I would posts here and see if anyone else has the same problem.

 

So, My original drivepool/scanner hard drive gave up the ghost abruptly.

 

With that in mind, I decided to move the hardware of the pc into another box. Now, bear in mind, none of the hardware changed, except for the SSD, which was replaced under warranty with the same exact kind/model.

 

Drivepool and Scanner had been running on this pc for probably nearly a year without any issue.

 

So I re-installed Windows Server 2012 R2. Fresh install. It has Hyper-V and Chrome on it and runs 2 VMs. It has 16 gigs of ram and is a I7 3.4 Ghz pc. It has 2 NIC's which are teamed (the switch it connects to supports LACP/LAG).

 

The version of Drivepool and Scanner may be different than what was running, I don't remember the last time I noticed an update from them.

 

So I start the scanner and it locks the pc up. I can still connect to the 2 VM's, at least for awhile. But I lose connectivity to the server that hosts the scanner and drivepool. It pings, but I can't login to it.

 

I reboot the server and I am able to get back in. It reports an unexpected reboot, but Event Log doesn't show any errors. I look at the scanner log and there's nothing in it I see that jumps out as an error.

 

So I let it sit like this for 6 hours. There are two drives that started being scanned, one at .06% and one at 0.0% and after six hours, they are both still at that same percentage.

 

I am just at a loss. 

 

Anyone else ever experience this?

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Default Windows Defender, nothing else. This server hosts VM's and will run Scanner and pretty much do nothing else, I won't browse on it.

 

No RST drivers, I'm not actually running it in a raid.

 

Running I have:

 

Chrome (because I can't stand IE)

Intel Management Engine Components (because otherwise I have an unknown driver in my list)

Stablebit DrivePool

Stablebit Scanner

MS Visual C++ 2010 x64 and x86 Redist.'

 

All windows updates applied.

Share this post


Link to post
Share on other sites
  • 0

does it lockup without the Vm's running? are the vm files in or out of the pool?

 

are all you drivers for your hdd controller(s) up to date? are they from you motherboard manufacturer or did you get them from the chip maker?

 

disable windows defender

 

disable drive pool and just run scanner - any difference?

 

disable both scanner and DP - run http://www.passmark.com/products/bit.htm - as a trial it will only run for 15 mins but helped find a very difficult obscure bug for me - do the read test on the disks all of them at once does it fall over now?

 

double check your cable connections for all pc components

re-seat all you ram

do a memtest86 run

 

see if that gets you an answer :)

Share this post


Link to post
Share on other sites
  • 0

It locks up whether the VM's are running or not. The VM's are on a 1TB performance drive that is not part of the Drivepool. 

 

The drivers are all up to date for windows, which are the default drivers I am running for everything except PCI Communications device that requires the specific motherboard intel engine management drivers. Bluetooth is disabled in the BIOS and unsupported in windows 2012 server anyway.

 

I'll run the passmark burn in tonight.

I reseated the ram when I installed it in the new box and it's all registering.

 

I'll run the memtest though tonight.

 

I'll also disable windows defender and drive pool and give it a try tonight.

 

The network cables are secured. It's setup with 2 teamed NIC's to a switch that is configured for LACP on those 2 ports.

 

Most of this I will have to try tonight when I am home, I don't want to crash it when I am at work :) lol

 

I'll update later on.

 

Thanks again.

 

Also, I do have a support ticket - I am working with support on this too.

 

I ran Burst Tests last night on every drive for an hour each and it worked fine, no crashing.

 

I set up the debug to get a memory.dmp, but it doesn't actually crash in such a way as to generate one.

Share this post


Link to post
Share on other sites
  • 0

I've had similar problems and am running (just installed a few minutes ago) a new beta for DP rather than scanner 

 

i had issues with DP when balancing (or scanner doing a burst test) it would crash but this was traced to two things 

a bug found in DP and that i had a duff controller card which i have just installed its replacement

 

i eventually traced my issue to the controller buy running burn in as 1,2,3 drives were fine but add a fourth and would crash within 15 minutes which was repeatable - the second controller runs 8 drives no problem

 

The things i suggested are some of the process i went through to try and eliminate aspects/hardware

 

I was getting obscure error messages - as having two controllers of the same model and make - with the error messages not being specific - it was guess work for a while trying to figure out which controller had the issue

 

Nailed it in the end :) and crossed fingers the new beta and the new controller play nice :)

 

Good Luck

Share this post


Link to post
Share on other sites
  • 0

Update to this post:

 

I worked with support and this thread here, but what ultimately resolved it was Burn In.

 

Burn In worked fine until I added in the OS drive, which is an SSD that passed all the manufacturer's tests with their utility.

 

However when I added it to the Burn In test, the server locked up.

 

Considering how much time i was taking, I finally decided a $50 SSD from Fry's would be a great way to determine if it was the drive or not and save me a lot of time.

 

So, I got a new SSD, installed it, the OS and Scanner.

 

Everything ran without locking up.

 

I added drivepool and continued to scan with no issues.

 

Problem resolved.

 

Thanks to everyone who helped.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...