Jump to content
Covecube Inc.
  • 0

Win7 Large Pool: 1 particular disk of 16, constantly disconnects/reconnects


surfyogi
 Share

Question

I have been using StableBit DiskPool for several years. I'm a true believer.

I rarely have to touch it, sometimes it goes a year at a time without much attention.

 

But recently, I see something I don't understand. My U: drive, is up and down, on and 

off the pool. It gets reported as off, and within a few seconds it has reconnected.

 

I have installed a power supply I think is big enough, since most of the disks are in

an external enclosure with it's own power. I don't see this same problem with

any other drive. 

 

I have moved the drive to different location in the cabinet, to test wires, power, etc. 

When I put it in an external dock, still does same thing..

 

So I cloned it to an identical new drive, and put it back in the main cabinet. New drive,

still does same thing. I have run dskchk on it, and it has a few problems, then it should be ok.

Every time I reboot, dskchk wants to give it some attention, but not that much, so I'm not sure what to do now. I've moved the data to a new drive, same issue; I'm thinking filesystem problems..

 

This may be a Windows thing, but still, it's got exclusively DiskPool files on it. And I have attempted

to remove and add it back to the pool. No help.

 

I am a veteran windows user, and I have tried everything I can think of (so far) to isolate this to a disk, or filesystem, or something I can deal with directly to fix it. 

 

I'm seriously thinking of adding a new drive to the pool, then migrate files off the new U: drive, and see what that does for me, but I can't imagine that should really be necessary. 

 

Any suggestions? 

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hi did you try the drive in a different bay in the enclosure if not it's worth a shot that would eliminate if it's the port for that bay that's failing or not, other than power which you checked the only other thing I can think of is I did have a couple of ocz ssd's do the same thing and after googling turned a lot of other people had the same problem crappy cheap parts hence I don't buy ocz ssd's anymore

Link to comment
Share on other sites

  • 0

I've moved it around, that's standard procedure. This is such a strange problem, I doubt anyone has seen it before me.

 

I've tried it in 2 different external docs, vs the internal desktop bay, and various internal bays. Identical behavior, even when I use a different disk drive with a cloned filesystem of the original.

 

1 drive of 16, one drive only.
 
It's taken me a while to isolate it, and never really have been able to..
- The drive is a problem regardless of drivepool service is running, or not. Windows 7 not happy..
- The drive is a problem even if I clone the drive (with cloning dock) to a new identical clone of the drive.
- The drive is a problem and constantly dismounts, remounts, even if I plug it into an external e-sata 
enclosure, or have it on board my desktop pc internally.
- The drive will not remove from the drivepool; it will dismount before operation can finish.
 
I've been pulling the files off the drive, in anticipation of not being able to use the filesystem that's
on it (which I have attempted to scan and fix several times).  Something with the filesystem, and Windows 7 does not like it.
I can use the drive in a dock, and read the files fine with a Mac.. and copy them to a new disk, new
filesystem, and that works just fine.
 
So I assume once files are rescued, then I can just format the drive(s) and they will work again.
 
Can you please point me to the most recent documentation, on how to replace a drive that will not Remove in the normal fashion, from the drivepool?
Link to comment
Share on other sites

  • 0

I believe that I'd already responded to this in a ticket. 

 

But yeah, this is absolutely bizarre.

 

have you ran "chkdsk U: /b" on the drive?  If not, that *may* help.

 

Otherwise, physically remove the disk from the system.  That will cause it to show up as "missing".  Remove the missing disk. 

If there was unduplicated data on the drive, then pop it into another system and copy the contents over to pool.  Or to another disk, and then move that disk to the system with the pool. 

 

 

 

Also, are you running any antivirus, backup or disk utilities (such as Samsung Magician or defrag tools)?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...