Jump to content
Covecube Inc.
  • 0

Accessing share folder on the pool crash Windows 10...


Question

I don't know what is happening, maybe a recent AV update but my server crash when I access some share folders.

 

The first time I did noticed it, I was doing some work on Photoshop, tried to save my file so it opened the last used folder, witch was on the server share and photoshop was kind of frozen.

I tried to remote desktop to rhe server and noticed it has just rebooted.

 

Whent to event log, a dmp file was created and few errors related to DrivePool.

I tried to read the .dmp and it says it can't load symbols covefs.sys.

 

Here are log events :

 

 Event 1 :

 

 

Exception:
 
CoveTroubleshooting.Reporter+ReporterLogException: {reporter_exception}
   à CoveTroubleshooting.Reporter.ThrowLogReportN(Exception TheException, Object[] TheParams)
   à CoveUtil.ErrorReporting..(Exception )
 
 
 Event 2 :
Error report file saved to:
 
C:\ProgramData\StableBit DrivePool\Service\ErrorReports\ErrorReport_2016_07_05-05_11_42.9.saencryptedreport
 
Exception:
 
System.InvalidOperationException: Not enough data returned.
   à #zcc.#C1b.#tKb[#wKb](SafeFileHandle , Int32 )
   à DrivePoolService.Pool.CoveFsDriver.FsControl.#sZc()
   à DrivePoolService.Pool.CoveFsPool.#9bf.#uZc()
   à CoveUtil.ReportingAction.Run(Action TheDangerousAction, Func`2 ErrorReportExceptionFilter)
 
 
 

I attached a few error reports in the zip

 

Let me know if you need the memmory dump, it's 200MB compressed.

ErrorReports.zip

Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Honestly, I'd feel more comfortable about handling this in a ticket (https://stablebit.com/Contact), as I may require more sensitive info. 

 

But for now, what OS are you using, and what version of StableBit DrivePool are you using? 

 

As for the crash, please upload that dump.  And the symbols issues is normal. We don't distribute these, as they are a couple of steps removed from source code. 

 

http://wiki.covecube.com/StableBit_DrivePool_System_Crashes

 

 

Additionally, this is definitely a driver related issue (as the error report indicates CoveFS was having issues, as well). 

 

I'd recommend uninstalling, rebooting and reinstalling StableBit DrivePool, just to make sure. 

Link to post
Share on other sites
  • 0

I was using Windows 10 current version.

I am uploading the memory dump.

 

 

So far here is what I have done (take a sit :D ) :

 

-clean uninstalled both DP and Scanner

-cleaned registry

-reinstalled only DP latest beta

-uninstalled Bitedefender Total Security (Control pannel/remove program + specific uninstaller)

-uninstalled Malware Byte  (Control pannel/remove program + specific uninstaller)

-removed folder associations between my hard drives and folders (was done to say to my AV to not scan those folders but rather scan DrivePool drive)

-run chkdsk /spotfix on my c drive

-run SFC /SCANNOW : it did come with some errors probably due to recent crashs

-run a second time SFC /SCANNOW : perfect, no error.

-run chkdsk /spotfix on my c drive

-uninstalled maybe 25 drivers to restore Windows 10 defaults one

-installed most recent drivers for each device even includind some firmwares

-flashed my mobo bios to latest version

-upgraded my Windows 10 to the latest slow ring insider preview

 

 

no luck, I still get those 2 event errors.

I didn't manage to crash the server again, but I am not sure why...

 

I hope my memory dump would say something to you.

I will wait for you to have a quick look at it but I plan to reinstall Windows at this point.

Link to post
Share on other sites
  • 0

I don't know if you had a look to my mem dump but anyway I decided to reinstall Windows.

I did sign for insider fast ring, as the last insider is very close to the august Redstone version.

 

To be more specific I did let the insider update proceed then I did reset Windows to start as clean as possible.

 

Installed again DrivePoll and it find itself my pool of 4 disks and everything looks ok, but I still face envent log errors and sadly managed to crash the server again.

 

This time I think I have norrow down the root of the issue : sharing this whole DrivePool disk.

 

It was working ok for month but now, sharing DrivePool letter and then accessing it from other PC crash the server.

Link to post
Share on other sites
  • 0

If it's the dump I think (and I'm not entirely sure, unfortunately)....

 

SMB is showing up right about the time the system crashes.  I linked the above build because it dealt with an issue like that explicitly. 

 

However, are the clients 32bit, by chance? 

 

Also, is this on the Slow Ring  (1151), or the Fast Ring? 

 

 

https://stablebit.com/Admin/IssueAnalysis/27101


Taking a closer look, if this is the dump I think it is ...

 

"trufos.sys" is loaded. This is the file system filter for BitDefender's Real Time Virus Protection.

 

Try uninstalling BitDefender and see if that helps (based on other issues we've had, I'm pretty sure it will)

Link to post
Share on other sites
  • 0

Hello, sorry for the late reply.

At the time the server crashed (and when the dump was created) it was running "standard" Windows 10 64bit.

That's only after having tried a lot of thing that I decided to go on fast ring and even on this fresh install I did managed to reproduce the crash.

On this new install, Bitdefender wasn't yet installed but only DrivePool and eventlog report was still showing this 2 errors.

 

But Bitdefender was installed on clients (Windows 10 64bit fastring).

 

So it would mean that a client running Bitdefender would be able to crash the DrivePool server without BitDefender?  :mellow:

Link to post
Share on other sites
  • 0

It may have been an older dump, or maybe the wrong one. Or unrelated. 

 

Either way, if you could upload the newer dump, that may help helpful, as well. 

Unfortunatly, I did wipe everything from c: drive  :rolleyes:

I could try to share again the whole pool drive letter to reproduce the crash.

I will do it asap.

Link to post
Share on other sites
  • 0

I will do again a clean install of the Win 10 machine running DrivePool when Redstone version would be released 2 august.

I will only install Windows as soon as some ISO would be released by Microsoft.

Then install DrivePool and won't install anything else.

 

I will then report if the 2 events logs remain.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...