Jump to content
Covecube Inc.
  • 0

Unable to remove a drive from the pool


Question

3 answers to this question

Recommended Posts

  • 0

Well, that's definitely not normal. 

 

Run "services.msc" on the system, and look for the "StableBit DrivePool Service". If it's not started, start it manually, otherwise try restarting it.

Or you can just reboot the entire system, and that will definitely restart the service.

 

 

If you could grab the logs from the system, just in case?

http://wiki.covecube.com/StableBit_DrivePool_2.x_Log_Collection

Just do steps #7-9.

 

 

Also, if you have a lot of unduplicated data on the drive, you may be able to use the balancers to clear out the drive. 

To do so, open the balancing settings (Pool Options -> balancing), and go to the "Balancers" tab. Find the "Drive Usage Limiter" balancer, and click on it.  Then find the disk in question in the list and uncheck "Duplicated" and "Unduplicated" for the drive in question.  Hit "Ok"/"Save", and this should cause the system to balance the data off of the disk. 

Link to post
Share on other sites
  • 0

I tried rebooting and had the same issue. I verified the services are running. I ended up installing the latest BETA version. It is letting me remove the drive, but it is showing all of my data in the other category. I can still get to it all, but it is a but worrisome. And my new NAS still need 2 days to finish the array build.

Link to post
Share on other sites
  • 0

Okay, glad to hear that the beta allowed you to remove the drive properly.

 

As for the "Other" data, you should be able to remeasure the pool to fix that (Pool Options -> Remeasure). 

And the measurement status/data affects the balancing, but not the actual data in the pool. So you should be fine regardless.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...