Jump to content
  • 0

Data Write Performance - low data throughput



Environment: Windows 8, 64 Bit - StableBit Drivepool 2.00.355. Four drives pooled into one pool. Shared over my G-bit network.



Currently testing the latest release 2.00.355 I have following issue with data throughput. Copying large files (e.g. over 40GB) over my G-BIT network I have a no constant data throughput by writing the file on the pooled and shared device. Throughput falls and raises again in betreen of 70 to 115MB/sec. By watching the new perf. monitor I see the measurement of the file written into my pool for 2 to 3 seconds (with 115 MB/sec). After that time Drivepool shows no activities (but my file is still copying to the shared drive). Then again perf. monitor shows the file activity of the pool. After 2-3 seconds again shows no activities. This symptom continous until the copy process ends.


First I thought that the buffer cache of Windows could be the root cause, but trying to copy with windows explorer shows the same symptom that the data throughput raises and falls in a cycled manner.


To test other unknown issues I have tried the following:


a) activated and deactivated the given performance options in DriveBender GUI (network boost, real time ....) without any change in performance.


1) Tested with an other pooling software "Drive Bender". Migrated my 4 drives to a pooled and shared volume in my network. Copying the same file delivered a constant throughput of around 110 MB/sec.


2) Tested with an other pooling software "FlexRaid". The same as with Drive Bender, a constant throughput of around 112 to 114 MB/sec.


Therefore I have to assume that only in combination with DrivePool I have this symptom with and steady performance drop and raise by copying large files on the generated pooled drive by using drivepool.


Any Idea how to figure out the root cause with my performance issue in combination with DrivePool? Are there any other users who had the same issue and found a workaround / fix for this issue?


thank you


Rainer (greeting from vienna, austria)


Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Hello Christopher


Thank you for your fast response. Temporarly I have used Flexraid temporarly to come over the performance issue. Yesterday you have announced the latest revision ( and I gave it a second try.


For your information only (maybe also interesting for other users): After re-installing DrivePool I had the issue that all my four discs have not been listed under "non pooled drives". (but the pool has been deleted already).


A user of this forum had the same issue (please refer to the topic called "Some drives not recognized by DrivePool") with your solution to stop the Stablebit DrivePool service and to delete all configuration files stored in "c:\ProgramData\StableBit DrivePool\". Re-starting the DrivePool service again, all drives are now listed up again.


So creating a new pool and the same files copied to the pool and the initial performance issue did not occur again. I have a good throughput now, so I'll monitor if this issue occurs again and give you a feedback after some days.


By the way: With deleting all settings files in c:\ProgramData\StableBit DrivePool\ I have an issue with my license again (hat to re-licence 2 times). So I "test and play" around with the trial licence and come back to you if everything seems to be stable not to re-activate my key several times until my "testperiod".


Thank you,


Best Regards,



Link to comment
Share on other sites

  • 0

WHen you delete the settings files, it does reset the license. 

However, if you try activating it, and it won't "take", try restarting the service and see if that helps.

If it doesn't, you may want to try reset the settings again.


And glad to hear that the performance issues haven't returned.

Link to comment
Share on other sites

  • 0

I had the same issue. I ran a transfer test to this morning when there was no pool activity and the transfer was stable all the way through: (Transfer of a 32GB file to my pool via a 1 Gig network.)




It only seems to bounce around when there is pool activity or scanner activity (at least in my case). I'll keep an eye on it though.

Link to comment
Share on other sites

  • 0

Well, for Scanner, you can change the disk activity sensitivity. 


And do you have the "Read Striping" and "Network IO Boost" options enabled for DrivePool (should be under Pool Options->Performance)



If you already have those enabled, if you wouldn't mind, could you enable "Tracing Logs" on the "server" and try duplicating the "issue" and then submit the logs?


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...