Jump to content
Covecube Inc.
  • 0

Feedback on CloudDrive


Question

Hi

 

I've been using DrivePool for a while, and the thought of being able to "raid" over several cloud providers really appeals to me so I instantly bought the app. I've been playing with it for a few hours and I'd like to give my first impressions.

 

Firstly I found the UI a tad confusing. Moving between cloud drives from left to right works, but it's a little none obvious, and then having to click the + to add other providers/perform attach operations is really confusing and took me (I consider myself quite an advanced user) a while to figure out. Personally I'd move the + button out of the existing drive selection and have it permanently visible. I realise it's the same as DrivePool, but I've only ever used one pool there so I hadn't even noticed the other options until I just looked now!

 

I also found the wording and the process surrounding adding a cloud provider very confusing depending on the provider. It took me ages to figure out when adding drop box that I had to click the authorize button, and for some reason it wasn't displaying the code on the stable bit site when I first tried it (perhaps you fixed something in the back end?). To fix this I'd recommend the following:-

  • Don't ask for Name if you need the username
  • Provide a lot more details if something fails - authorization error just led me to guess a lot
  • If you need to do OAuth then do it in a window in side the app, and parse the token automatically rather than copying and pasting between your site.
  • Please put some help info in the how do I connect to this provider (I'm guessing thats the plan in the long run!)
  • Some file shares don't require a username/password, so you need to make that optional
  •  

I also couldn't figure out the point of adding a local disk - I'm sure I'm just missing something obvious here!

 

I've had a few times where it's looked like the app has crashed, but it hadn't I just needed to be patient (which I'm not great at!)

  • When creating a Disk it often loses connection with the service and advices you to restart the machine (waiting a long time appears to fix this, but I have no idea what it's doing)
  • I'm not sure what caused it, but while looking at the networking drive explorer totally froze. I went into CloudDrive and it was doing something called Pinning. Again no idea what that is.

I've also had drives mounded, but I can't see them in explorer at all (nor in the Disks in File and storage services) so I don't know whats going on with it. In Drive pool I can see some drives in the non-pooled area called COVECUBECloudFSDisk___ but I don't know which provider they relate to.

 

I tried clearing all the feedback and got some issue with it being unable to communicate with the Pipes - sorry should have taken a screen shot of that.

 

I added a network share (which got added as drive J), put it in a drive pool, then started adding other cloud providers to my machine (not in the drive pool). After the issues above and a restart my network share didn't exist in my list of drives (and the drivepool has reported the disk is missing). I can't re-attach the drive because stable bit is telling me it's already mounted, but it also doesn't appear in the list of drives. This issues is shown here:

 

post-2013-0-12391800-1433496553_thumb.png

post-2013-0-21783600-1433496702_thumb.png

post-2013-0-59265200-1433496707_thumb.png

 

Also none of the disks created (amazon, box and the network share) appear in file manager so I'm really not sure whats going on!

 

Whilst I have pointed out a lot of issues I'm having I do love the idea of this product (especially the TNO encryption!)... but unless people are having a lot more luck than me I think this is more in Alpha territory, and I can't recommend anyone relying on this for real data at the moment!

 

I really look forward to seeing how this product progresses, and I hope this post has been useful.

 

[EDIT: one more screen shot that might be helpful!]

post-2013-0-72243000-1433497004_thumb.png

Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Ross.dargan,

 

Well, thank you for the feedback.

We definitely appreciate it, as it definitely helps us.

 

 

 

For the multiple provider/CloudDrive UI, I've flagged that Alex (the developer), to see if we can improve upon that (maybe a wizard to start off with, to make it easier to understand).

https://stablebit.com/Admin/IssueAnalysis/16681

 

As for the Provider setup, we definitely do plan on improving that in the future. Though, again the feedback is appareciated as it helps us with what exactly should be changed.

https://stablebit.com/Admin/IssueAnalysis/16682

 

 

As for the local disk, there are two use cases for this:

  • Creating a CloudDrive on StableBit DrivePool (this would allow you to get VSS/backup support),
  • Or as an alternative to TrueCrypt or the like, as you can encrypt the CloudDrives. 

 

 

As for the service stuff, it shouldn't restart the service or need you to restart the computer. It's failing at some point here, then.

In this case, could you grab the error reports from the system?

http://wiki.covecube.com/StableBit_CloudDrive_Error_Reports

 

However, this crashing is probably the cause of some of the other issues you're seeing. By default, StableBit CloudDrive should automatically partition, format and then assign a drive letter to newly created drives. Because the service appears to be crashing at some point, it is not completing this process for you.

 

This is why you're not seeing the drives listed in the "This PC" properly, and why you're seeing the "COVECUBECloudFSDisk___" (the disk's hardware ID name) in StableBit DrivePool. 

 

You should be able to use Disk Management (run "diskmgmt.msc") to manually assign these drives letters (again, this should be happening automatically, but because of the above issue... it's not).

 

 

As for the Pinning, this "pins" files to the local cache. Specifically, we "pin" the file system data to the cache, so that it's always available (eg, so you don't have to access the cloud provider each time you query the file system). And you can optionally pin the directory entries, as well.

 

 

As for the network share provider, you should force attach in this case.  This is happening most likely because of the service crashing. 

Specifically, we only allow a drive to be attached to one system at a time. However, due to the service crashing (most likely), it's lost the association, and is prompting you about attaching it to this "new" system.  This is a precautionary warning to prevent data corruption (eg, uploading the same chunks from different systems).

 

 

As for clearing the feedback, I'm guessing it mentioned the "named pipe service" specifically.
If that's the case.... You may have an issue with your installation, as this is a core .NET Framework feature.

This ... may also be the cause of the Service failing as well.

In this case, run "chkdsk c: /r", and after that, "sfc /scannow", to ensure the integrity of your installation. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...