Jump to content
  • 0

[solved] WHS 2011 sharing + HomeGroups has busted DrivePool 1.x



Hi there,

I'm in an unusual situation now. I think it is due to HomeGroups having screwed up permissions on my Shares - which were OK, until I made a mistake.

Or maybe DrivePool has become totally busted and these are coincidental issues.


So I need to repair the situation.


I have purposely NOT used HomeGroups prior to Windows 8.1 on my clients, but apparently, WHS 2011 cannot properly share music and videos into Xbox Music / Video unless those shares are part of a HomeGroup. It sort of explains why my music was always half in / out of "streaming" or "cloud" etc.


Here's my first mistake:

I created a HomeGroup on Windows 8.1, but JOINED it in WHS 2011 via the Networks and Sharing panel, NOT the Dashboard (I totally forgot that the feature was there).

Well, that started to work... but then stopped.


I unjoined the HomeGroup, then re-Joined via the Dashboard and got a much better looking set of options with all the WHS Shares that DrivePool knows about.

That seemed to start working, but never really completed.



Now the WHS Dashboard will open and sometimes the Server Folders and Hard Drives tab will populate (at first run), and sometimes will not.

The little "running animation" on top of the "Pool Condition" gauge never ceases to animate even if it is populated.


So I think DrivePool is somehow damaged.


DrivePool support info:

I ran the "NTFS Permissions Reset" tool from the WSS support page, and also reset all my Media Information.


Other items about Sharing:

In the Advanced Sharing Setup, I have selected "Use the same Windows Accounts for HomeGroups (recommended)" now (it wasn't before).


And I have enabled sharing there, but not streaming.


Streaming is enabled in the WHS Dashboard Settings (which I think is correct).



The result is that no shares at all are available anywhere, even if they appear in the Dashboard (e.g. via Network, or the WHS Web site).

I also get a 8004008A error on certain folders if I look at the Sharing Tab from the "View Folder Properties" on the Server Folders and Hard Drives tab.



My theoretical fix:

  • Make a new temporary share in WHS / Drive Pool (e.g. zVideos).
  • Move contents of a broken share into there (e.g. move via TeraCopy).
  • Delete broken share in Dashboard (?).
  • Create new, good share with good name (e.g. D:\Videos)
  • Move to DrivePool (-> Z:\Videos which is where it was)

Lather, rinse repeat...


But right now, operations in the Dashboard don't actually work... like "Move the Folder" starts with "Calculating the folder size" and nothing happens.



Link to comment
Share on other sites

11 answers to this question

Recommended Posts

  • 0

I've not heard of the issue with sharing that you have mentioned. However, it is much easier to set up with HomeGroups. 


However, as you've basically learned, HomeGroups are horrible, and it's implementation is atrocious at best. :(


To be honest, I would recommend removing/disabling the homegroups and go back to a "work group" layout.

In that scenario, you'd need to have matching user name and passwords... or store the correct ones in the "Credential Manager" (Control Panel->Users).


As for the shares... make sure you reconfigure them in the dashboard, and that will "restore" their permission settings, and may fix the issue.

Link to comment
Share on other sites

  • 0

I may have to use HomeGroups to get Windows 8.1 / Xbox Music to see all the music in my shares properly. Right now, I have them in libraries, but WHS's LaunchPad, even when my accounts all line up via Credential Manager, still doesn't properly sync my music.


The solution appears to be "HomeGroups".


Anyhow, the real issue now is that no operation completes in Dashboard anymore...

I can't make a new Share, Move a Share, etc.


It's like something got unregistered, or the permissions need to get reset somewhere.

Link to comment
Share on other sites

  • 0

Ah, okay.


And yeah, specifically the issue is that it will not let you add locations that cannot be indexed. And you cannot index network shares normally. 


I think the only way to do that would be to configure the folder to be available offline (using "Offline Files" feature). The downside is that this will cache the contents to the local disk. But it will be indexed.


Unfortunately, HomeGroups cause all sorts of other issues, and don't work as well as it's advertised to.

And since HomeGroups is basically "hacked" into WHS2011, it sounds like you've definitely broken something here. And unfortunately, I suspect that it's related more to the home groups stuff, than for the storage service or DrivePool.


You can verify that by creating a custom shared folder on the pool. To do so, create a new share, add "Everyone" to the allowed users, and set it to "Everyone". It should show up in the dashboard (may require a restart). From there, you should be able to modify the permissions on the dashboard. 

I'm not 100% certain of this, but would be worth checking out.


Alternatively, if you have a backup of the server, I'd recommend backing up to before you made the configuration changes and "be done with it". However, if you don't have a backup....






Also, if the issue is moving the folder to the Pool.... Running the "WSS Troubleshooter" utility, and selecting the "Rebuild DrivePool Shares (OS reinstall)" option may work to "force" the share to that folder.


Link to comment
Share on other sites

  • 0

Hi there,

So I think I have finally remedied (or made HomeGroups behave) the situation based on a combination of the suggestions...


Here's how it went, after about a month of screwing around, I think this is reproducible and Windows 8.1's Xbox Music appears to be behaving as it should be.


  1. I had to un-join my HomeGroup (in all ways - via the Network and Sharing center and Dashboard Settings - check both just in case)
  2. Make temporary folders in your DrivePool ServerFolders for each share you have, move you content in each one
    1. So, create "Music_backup" etc.
    2. Move all files in your exising "Music" share to "Music_backup"
  3. Let DrivePool sit with those changes for a while
  4. Reboot
  5. Open Dashboard - see if you can remove the old shares (I couldn't remove the default shares - or any really via Dashboard)
    1. If you can't, do a "net share "Music" /delete" from a command prompt instead
    2. Delete the "Music" folder from your ServerFolders
    3. Lather, Rinse, Repeat for every folder
  6. Let DrivePool sit for a while - it needs to remove all the folders from all the duplication areas
  7. Reboot
  8. Open Dashboard
  9. You should see it has detected "Missing Folders"
    1. That's good
  10. Now, open Start Menu, type Search
    1. Change Locations Windows Searches
    2. Remove all the shared locations it can't find
    3. Apply / Close
    4. Let it sit
    5. This removes all the old entries that help you find all the content you used to have
  11. Go back to Dashboard
  12. Here's where you create a HomeGroup if you want (skip 13 otherwise)
  13. Open Settings
    1. Click HomeGroup
    2. Create HomeGroup
    3. This should finish quickly because there is nothing there...
  14. Re-create all your Shares in the default D:\ServerFolders\ locations
    1. If you made a HomeGroup, select appropriate permissions
    2. Make sure Guest has No Access I guess.
  15. Move Shares to your DrivePool location
    1. They'll be empty
    2. Shadow Copies will probably fail
  16. Go to File Manager
  17. Move your content back into your folders
  18. Click Start
    1. Type Search
    2. Change locations where Windows Searches
    3. Make sure Windows is Searching your locations (DrivePool paths) and nothing is broken
  19. If you made a HomeGroup, check your permissions
  20. Make sure your Music Library has the DrivePool Music folder
  21. After DrivePool has sat for a while with your changes
    1. Turn Duplication on for your shares via the Dashboard
    2. Open File Manager and remove your "Music_backup" folder(s) for your temporary shares
    3. They may not go away until another reboot

That's what I did, and now everything seems happy.

I see some folders via HomeServer in a HomeGroup, and ALL shares via my permissions in my NETBUI server path. And all my Dashboard stuff works, and my index is correct now...


I had a few other issues going on - it turns out Windows Backup was filling up my drive without removing Shadow Copies.

Also, Windows Search had an invalid library location blocking it from updating my Music index, so DrivePool was having trouble rebuilding its index.

And, I seem to have some sort of "Controller Error" on a USB drive (not part of the pool) that I can't seem to track down.

The drive doesn't report any errors on the disk, so I don't know what to do about that...



Link to comment
Share on other sites

  • 0

That's .... overly complicated, but I'm glad that you found a solution.


As for the WIndows Search, this may help:



For the "Controller Error", is this happening when the USB drive is under heavy usage?

And do you have StableBit Scanner installed?

Link to comment
Share on other sites

  • 0

Well, I mean the entire process (without reboots) takes about 20 minutes.


It's basically "put data from your shares in a temporary, parallel set of folders";

Destroy original Shares;

Make a HomeGroup;

Make new Shares via Dashboard in their default location (make sure permissions are like you want them)

Move them into the pool.

Remove the temporary folders you made.


I gave DrivePool a chance to duplicate things around.


The Search thing I discovered afterward - "Music" wasn't indexing in DrivePool and I couldn't figure out why... turns out Windows Search database was corrupted.

There are several ways of fixing that. This method was "Point and Click".


I don't have StableBit Scanner installed - The USB drive is really sort of just hanging out. It doesn't get accessed very often.

It could be not responding to "sleep" or events like that?

There was a bad file on the disk for some time, but chkdsk doesn't seem to do anything about it anymore, so maybe it's gone...


After all this, DrivePool isn't using one of my 3 disks (it literally is using 2 out of 3 for my duplication needs).

So that's weird.

Link to comment
Share on other sites

  • 0

Okay, good to know that it doesn't take that long.


As for Windows Search, the database for that seems to get corrupted fairly often. :( 


For the USB drive, does the disk become inaccessible or experience any other sort of issues? Or is it just appearing the event log?

And as for chkdsk, sometimes the normal fix pass doesn't work, and you need to run the "/r" option to get that working.



As for DrivePool, is the disk that isn't being used smaller than the other two? If so, that would be why. Specifically, we place files on the disk(s) with the most free space. Since this is the absolute value and not a percentage, smaller disks may not be used until later on. The "Disk Space Equalizer" balancer changes that behavior, if you really want:


Link to comment
Share on other sites

  • 0

That USB drive is mostly a GoodSync "backup" destination for the shares (www.GoodSync.com - I used it as a replacement for Live Mesh) - so it doesn't get used continuously.


I'll kick off the jobs though and see if anything funny happens.



Yes, that "unused" drive is now the smallest of bunch - I added a larger one a while ago, and I think DrivePool has been moving files off of it. So that makes sense.


I guess I could physically remove it and keep it out of the pool so it isn't spinning all the time.



Link to comment
Share on other sites

  • 0

Okay, it could be the activity that is causing the error. However, depending on the error, it may be harmless. What event number was it?




As for the unused disk, I had a feeling it was smaller. You could definitely remove it, however, it will get used once the other disks have the same amount of free space left. So you may want to keep it in there, depending on how much you add to the pool on a regular basis.

Link to comment
Share on other sites

  • 0

I think it was an Error 11 - which sounds pretty serious.

After doing a zillion operations on it via GoodSync (MD5 comparisons on 250GB of data, and syncing folders a few times), I don't see any of the errors there.


I'm wondering if it is some sort of spin up / down event?

Anyhow, I figure it should have been triggered by now...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...