Jump to content
Covecube Inc.
  • 0

File Attributes Change Copying From Pool


Question

Hi, I have come across an issue that is affecting a small number of files in the pool that I can't get to the bottom of. Basically, if I copy an affected file from the pool to another location (local or network) then the file in the destination has either a different 'date modified' attribute or it has a different file size. This was brought to my attention when my backup software kept backing up the same files because it detected that the destination file was different to the source file so it assumed the source file had been modified. At first I thought it was my backup software acting strangely but it turns out I'm getting the same results even if I copy the files manually.

So I have done some testing and found that if I copy the file from the pool then I get the issue, however if I copy the same file from the original drives ;PoolPart.xxxx' folder then the destination file has the correct attributes and file size. Here are two example files that exhibit the behaviour.

 

File 1.  A JPEG file that is 42,718 bytes in size and has a modified date of 18 Dec 2015. When I copy it from the pool the destination file is 51,759 bytes in size and has a modified date of 13 Sep 2015.

If I then copy the same file from the respective disk's PoolPart.xxx folder then the destination file's size & modified dates are exactly the same.

 

File 2.  A FLAC music file that is 78,461,914 bytes in size and has a modified date of 31 Jan 2017. When I copy it from the pool the destination file has exactly the same size but has a modified date of 23 Mar 2015. 

Once again, if I copy the same file from the respective drives PoolPart.xxxx folder then the destination file is exactly the same.

 

I can only assume that when I copy from the pool then it is accessing a different file but I don't know how or why. Also, only 17 files out of approx 20,000 are effected.

So any help would be very welcome.

 

Thanks

Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Just a quick update. I have found that the effected files had two copies on different physical drives in the PoolPart.xxx folders. I don't know how the duplicates got there but I'm sure this predates my use of DrivePool and probably originated when the drives were in a FlexRAID array.

I have now deleted the duplicates and things are looking much better.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...