Jump to content
  • 0

Plex + GDrive creating new library


Chupa
 Share

Question

Hello, I changed PC and I am creating from a new library on Plex with the content inside my CloudDrive disks, after having mounted the disk and assigning them a letter I proceeded to change the owner of the disk as you read in this Christopher procedure and then I mounted my disks inside a folder instead of assigning them a drive letter.

 

 

I noticed that the matching on Plex is extremely slow, and by extremely slow I mean that I added a folder with 3 TV series for about 127 files and an average weight of 1 GB per file and it took about 1 hour to complete the matching, I have read that it takes longer when creating a new library than when adding to an existing library, however I am starting to think that there is something wrong with my settings that I could change to speed up the process, the settings that I have adopted I found them on the forum and I think they are good for streaming (actually I have never had problems) only in the matching phase I have always found a certain slowness.

Below is the information and a screenshot of the settings
Connection: 1 GB / S symmetrical
CloudDrive version: 1.1.7.1391
OS: Windows Server 2016
Cache: Dedicated SSD

image.png.4ab90b416638190f12c445e8907bafe8.png

 

Anyone have a good idea on how to change the settings to speed up the process?

Thank you all

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

I see quite good plex scanning and matching behaviour, so I will describe my setup, hopefully it helps.

I have multiple clouddrives pooled together using drivepool (I don't think this affects scanning but It is worth mentioning)
My clouddrive is running in a windows server 2022 VM (Hyper-v) with 8gb of dedicated ram and 8 dedicated threads (ryzen 9 5950x)
The cache is running from (a virtual disk on-) a pcie gen 4 nvme ssd.

Each individual drive is set to the following:
Chunk size 20MB
Cache chunk size 100MB
Cache Size: 10GB Expandable
File system: NTFS
Data duplication: Pinned data only
Upload verification: Enabled
Pin directories: Enabled
Pin metadata: Enabled
Download threads: 5
Upload threads: 5
Background IO: Enabled
Throttling disabled
Upload threshold: 1MB or 5 minutes
Minimum download size: 20MB
Prefetch trigger: 1MB
Prefetch trigger time window: 30 seconds
Prefetch forward: 100MB

From these, it seems to me that either the prefetch trigger or the pinning might be the cause of the slow scanning/matching.

It is worth noting that plex now includes a feature that detects intros in tv shows (to allow you to skip them) which takes a pretty decently long time to detect, it could also be that this is what you are seeing. If you continue having issues I could share my plex settings with you as well.
 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...