Jump to content
Covecube Inc.
  • 0

One drive in pool gets corrupted, turns into GPT Protective Partition


Posted (edited)

I have a simple pool I'm testing with 2 drives in it. I want to end up using it as the data drive on my living room media PC: it mostly gets the hand-me-down hardware, so it will probably end up having a handful of smaller drives, and I'd like to pool them so I don't have to bother tracking which files end up going on which drive. Most of the space will be used for either media or a Steam library, and potentially program installs if the boot drive ends up running out of space. I have also removed the drive letters from the individual drives so that it just appears as I just have one large drive connected.

I can easily copy >70 gigs to the drive from my NAS (using robocopy), and everything is fine (although I did notice that one drive tended to fill up much more quickly than the other drive, but I haven't investigated the balancing features yet; none of my files also appear to be duplicated except for the metadata, but I haven't turned any duplication settings on, so hopefully that's correct, as I don't actually want anything duplicated).

However, if I setup a Steam library on the pool, I find that after around 10-15 gigs of a game has been downloaded, something gets corrupted in the pool. All of the space on the 2nd drive is suddenly listed as Other, and Steam starts failing to write to the drive as it downloads content. If I attempt to add a drive letter back to the 2nd drive so I can run chkdsk or diskpart or anything else on it, the partition is turned into a GPT Protective Partition. Presumably this means there was some partition or GPT corruption on the drive? At this point I haven't found any way of restoring the partition without just cleaning and re-formating the drive. After the partition gets set to a GPT Protective Partition, DrivePool reports the drive as Missing (although it still shows drive usage, with everything listed as Other)

Both disks pass all SMART checks, drive self-tests, and generic read tests (both long and short reads) done via SeaTools.

Things I haven't tried:

  • Making a new pool with the drive orders switched, to see if the same drive fails
  • Recording any DrivePool traces (I can try this, but I don't know how difficult it would be to grab the exact moment it fails... I don't want to sit around watching 15gb to download just so I can stop recording the log as soon as Steam gets an error)
  • Running dpcmd on the failed drive. I would have to do whole process above without removing the drive letters on the individual drives, but I also assume that once the drive gets corrupted, there is no meaningful filesystem on the drive to check anyways

I have, however, tried the above mentioned process several times, and it always fails in the same way. Does this seem like a drive failure? Or is something about the way Steam is writing to the pool causing this corruption? Is this not a recommended use case for DrivePool?


Any help is greatly appreciated!


P.S.: I did a Scanner pass of both drives, they both report green on all sectors. I did actually discover though that the "good" drive (which reported OK on SMART tests through SeaTools) actually has a single reallocated sector, although presumably this isn't causing a problem for the 2nd drive (unless some metadata is getting corrupted somehow? seems unlikely since all sectors were verified)

Edited by markb
Further test results

Share this post

Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0
On 3/26/2020 at 11:38 AM, markb said:

although I did notice that one drive tended to fill up much more quickly than the other drive, but I haven't investigated the balancing features yet

This is likely normal.  New files are placed on the drive with the most free space. This is measured absolutely, and not based on the percentage used. 


For the rest, that's definitely not typical.  I store my steam library on the pool, without any issues...

However, if this is happening, it sounds like the partition stable is getting screwed up.  If the drive still has a drive letter, then you may be able to fix it by running a CHKDSK pass on the drive.   Otherwise, you'd want to run data recovery on the drive. 

However, if it's the same disk that has this happening to it, then it may be simpler to just remove the drive and replace it. 

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...