Jump to content
Covecube Inc.
  • 0
caramonn

Balancers not working as expected with different sized drives

Question

I've been using DP for a few years now along side Snapraid. Recently I started upgrading my drives from 4TB to 10TB. I changed out my first data drive to 10TB last month and have noticed that DP, even though told to equalize space by percent used, continually tries to place new files to the 10TB drive even though that drive is more full than the rest based on percent used. It will drive it down to less than 8% free space until I have to force Automatic Balancing to correct it, while the rest of the 4TB drives are at 11.5% free space.

I do not have Automatic Balancing enabled, but rather use the plugins for new file placement. If I do nothing else, but enable Automatic balancing, it redistributes the files to make all drives equal in space used, which is about 88.5%, which is correct. 

I've tried changing the settings to percent of free space remaining with the Disk Space Equalizer plugin and that had no effect. Currently the 10TB drive has 89.2% used, while the remaining 4TB drives are sitting at 88.4% used. Every morning my report shows all new files going to the 10TB drive.

 Am I missing something or is this a bug?

DP1.JPG

DP2.JPG

DP.JPG

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

By default, StableBit DrivePool places new files on the disk with the most available free space, measured absolutely, not based on percentage. 

Even with the Disk Space Equalizer balancer plugin, this isn't going to change, as it doesn't use the real time placement limiters. 

Share this post


Link to post
Share on other sites
  • 0
19 hours ago, Christopher (Drashna) said:

By default, StableBit DrivePool places new files on the disk with the most available free space, measured absolutely, not based on percentage. 

Even with the Disk Space Equalizer balancer plugin, this isn't going to change, as it doesn't use the real time placement limiters. 

Thanks for the reply. Is there a plugin that I can use to change this behavior?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...