Jump to content
Covecube Inc.
  • 0
ironhead65

Box Account, uploading FOREVER, cannot STOP/PAUSE

Question

Hi all,

Been experimenting and I think I found a bug, however, I did not want to do anything until I ran it by the community.

I have signed up for a Free BOX.com drive.  You get 10GB of space.  What they did not tell you, is it seems you have less than that.  I took a guess that they used hard drive manufacturers 10Gb (not 10gb) and it really was 9.7GB (there abouts).

I found this by using this drive in a Drive Pool.  The pool got saturated and that drive had over 9.7GB of data.  That is, the drive was over 90% full.  As Cloud Drive was trying to upload, it seemed to get stuck in a loop.  After I noticed that this ONE drive was taking ALL my upload bandwidth, I hit PAUSE though the new PAUSE button.  I validated that the settings changed (manage drive -> Performance -> Uploads UNTICKED).  I also tried to use the "All drives PAUSE" under the pulldown (upper right Gear).  Nothing I did could stop the upload from happening.  I was sure this was happening as pulling the ethernet cable from the VM seemed to stop the upload (from the upload speed value being shown).

After I plugged the ethernet back in, and a few hours later (I honestly do not know how long it was), I logged back into the machine and looked.  I had a message in the message ticker that stated the drive was FULL and the upload attempt failed 260 times.  EEEK!  I also saw at least 1 other box drive listed in the log.

I then tried to STOP and RESTART the Cloud Drive Process.  This only seemed to anger other drives (now they had GB of data that was out of sync - this was being addressed in a Cloud Drive thread regarding rebooting and seemingly getting this error, which was brought to a conclusion with a TR/SR being submitted, so I did not bother...well bothering anyone about it).  OK, all that aside, this drive was NOT going to stop trying to upload.  I then tried a reboot.  Still, no change.  For a while, I just TURNED it's speed WAY down.  That let other drives "catch back up" from the service stop and the reboot.

At this point, I now think I discovered the issue.  I changed a few settings on Drive Pool to fill to 80% as best it can, instead of 90% (just to be safe).  I also mapped my box accounts to drive letters.  Then MOVED an appropriate amount of data off to let me use the resize feature and set to 9.7GB.  It seems just doing the move has made cloud drive happy and EACH drive that was STUCK like this has STOPPED trying to upload.  I have only tested this with box (hence the post here).  It might be with all - however there was a pretty long check when I SETUP the Google drives.  If I put in a value that was too large, the original drive creation would fail.  I would think this is the same with BOX?

I am on the latest beta 1.0.2.963

 

So, has anyone else seen this?  Any tips?  Is this just BOX?

Thanks!

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Chris,

Thanks!  I'll check this out soon.  For now, I just removed all the BOX drives and it seems to have made everything happy again.

It could have also been causing a LOT of pool inconsistencies (where formatting or just purge and re-add was the only way to "fix" the Drive Pool issues with these cloud drives).  I cannot be certain, as I never saw "I did this thing" then Drive pool went wonky.

So, I have not posted about it.

For now, I have been using ONLY Google Drive and removed ALL other drives.  That means my space dropped quite a bit, but I see with only 11 drives (as few SMB as well), my processor use has dropped from being pegged to 100% for DAYS on end, to rarely getting over 10-20%, and when it does, it is for seconds.

I think in total, just to push things, I had 44 drives in there.  That was unhappy.  I am thinking even with the UPLOADS paused, there was something else going on all at the same time?  Pinning data maybe?

For now, with the 11 drives, I have not had to run my script (which I never uploaded to you as I've found issues when the processor use is HIGH...the script fails in a strange way).  Maybe I should post it privately to you just so you can see what I was trying to accomplish (and seemed to help quite a bit)?

Thanks!

Share this post


Link to post
Share on other sites
  • 0

Well, as for the CPU usage, I/O access is "expensive". So if you had a LOT of drives, (and 44 is a lot!) that could potentially bog things down, especially if you have a lower end CPU. 

 And yeah, even with it paused, it's still downloading from the provider, and it's still reading and writing data locally. So, a lot of I/O still.

 

As for the script, no, that's fine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×