Jump to content
  • 0

Accessing server files from Mobile device


dbailey75
 Share

Question

Ok, question for the experts, more like advice, how are you accessing data on your server with your mobile device, for me, it's an Iphone.  I've been looking at some apps, cloud storage, but I really don't want to use the cloud,  So there's an iphone app called Filebrowser which will let me access my files like SMB shares, which is half of my goal,  I would also like to be able to upload my photos, when I'm out and about, and delete from the phone to save space (or if I lose the phone) and skydrive seems to work for that, found another app called Tonido Desktop which may do both, haven't installed it yet.  If the the app worked for streaming , thatwould be great but not necesary,  so instead of reinventing the wheel, figured I see what you all may be doing.

 

http://www.tonido.com/tonidodesktop/

http://www.stratospherix.com/

 

 

 

Link to comment
Share on other sites

Recommended Posts

  • 0

Ok, I removed RWA from gateway, and added it to the PC Name, success. 



Also, what is this exaclty, webdav add in for 2011, and the there's a web dav app for IOS.

I got this going too, using webdav Navigator+ for IOS, so I can access any file on my server, and up load from my phone as well, I had some old giftcards to use, so figured what the heck.

Link to comment
Share on other sites

  • 0

The issue with using "Gateway" is the Remote Desktop Service is not enabled in WHS 2011.

 

I used most of the steps found here.

http://www.rayheffer.com/953/building-a-remote-desktop-gateway-rdg-rd-gateway-server/

 

RDP app

Configuration-Gateway

Add Gateway

Server (xxxx.homeserver.com)

Credentials (username and password)

 

New Remote Desktop

Connection Name (optional)

PC Name (LAN IP or Machinename)

Username (username)

Gateway (xxx.homeserver.com)

Link to comment
Share on other sites

  • 0

I tested various connection settings for the MS Remote Desktop for Android using my phone, both with Wi-Fi enabled (on my LAN) and disabled (over the Internet on 4G).

 

(My WS2012R2E server is setup for normal RWA with the router forwarding only ports 80 and 443. I'm pretty sure the connection results I found would be the same for WHS2011 as well. The server and all my client PCs have remote connections enabled (under Remote settings in System properties, and the Network Level Authorization restriction is unchecked just because I want the lowest common denominater for access from earlier OSs).

 

This is what I found:

 

1. On the LAN with Wi-Fi, no Gateway is needed. Voila! Just using the Server’s or other PC’s computer name for the PC Name gets you there.  (Using the RWA URL for the Server is a dead end, which I expected.)


2. On the Internet with 4G,  without a Gateway, I can’t connect even to the Server using either the computer name or the RWA address (xxxx.homeserver.com or remotewebaccess.com) for the PC Name.  But once you setup your Server as the Gateway with the RWA address for its PC Name, you can jump onto the Server or any other LAN PC using just the computer name in the PC Name for Remote Desktop connection (with that Gateway specified.)


3. Assuming that you leave the credentials fields blank when you set up the app connections, if you have the same credentials on your Server, which is the Gateway, and on your other PCs, then when you enter your credentials for target computer (Remote Desktop), that will be the only time you’re asked, because those same credentials will pass to the Gateway. This is the case, for example, if your target is your Server, which is one and the same as the Gateway. If the credential for your Server and target Remote Desktop are different, you’ll enter credentials for the Remote Desktop and then be asked again for the Gateway.

 

So I set up two Remote Desktops for each computer I want to access, one for the Internet and one for the LAN, depending on whether I’m at home or not; e.g., Server and Server LAN, with Server LAN having “None” for the Gateway.

 

It’s really that simple for me.  I’ve done all the manual firewall and port settings in the past when I set up WS208R2 Hyper-V Server w/no GUI.  But I prefer it to be easier when it can be.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...