Jump to content
Covecube Inc.
  • 0

GSuites: Download Quota Errors




Hoping someone can help me out with some constant errors that I'm seeing.


I have unlimited storage via GSuites (5 accounts). 


I continuously receive the same errors from both my GDrive Storage containers;




I/O Error:


Cloud Drive (G:/) - (Drivename) is having trouble downloading data from Google Drive. The operation is being retired.


Error: The download quota for this file has been exceeded.


The error has occurred 44 times.


Make sure you are connected to the Internet and have sufficient bandwidth available.





Here is my setup;


Dual Xenon (2670's) on a dedicated VPS. 1 GB up/down, tons of bandwidth available. So hardware and bandwidth should NOT be a problem.


Only use primarily for Plex. Maybe 5-7 users simultaneously max but generally 3-4 users is the average. I use local VPS drives for Radarr/Sonarr/etc. 


I'm wondering if perhaps the issue is happening because of the 5 Gdrive accounts I purchased, I do have both of my gdrives drives in the same email account (256TB x 2, 150GB+ cache, 10 threads up/ 5 down, 250MB throttle up/down, upload threshold 1MB / 5 min, Prefetch 10MB / 100MB / 120 sec (have tried 60 sec and 240 sec also)).


Perhaps my quota error is because Google looks at each of the accounts as aggregates and not individual drives? so hence it sees 20 threads up / 10 down?


Or any other advise someone can give? 



2nd Question: 


Has anyone tried using the read-only feature of Clouddrive for Plex? I'm thinking of uploading data locally, but only have my VPS have read-only access to the media that is being transferred for Plex.


Thanks in advance.

Share this post

Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Was this a drive that was created with an early version of StableBit CloudDrive?
If so, then the "download quota for this file" issue is from the structure/size that we used for that.


This issue has to do with the individual files on the account and how often they're accessed, and nothing to do with your account type.


In either case, try detaching the drive, and re-attaching it.  When attaching it, open the "Advanced Settings" and set the "Minimum download size" to 5-10MB, and then attach it. See if this helps prevent the issue in question. 


Also, try reducing the number of threads that you're using. Try not to use any more than 10 for either.  Less is more in this case, actually. 




As for the second question, I haven't tried this personally, so I couldn't comment on it. And that should work fine, I think. 

Share this post

Link to post
Share on other sites
  • 0

Thanks Chris,


I created the volumes with this release version; StableBit.DrivePool_2.1.1.561_x64_Release


I'll attempt to re-attach to see if that fixes it, but I already have it at 5MB for minimum download size. I'll report my findings on this thread.


When you say to reduce the number of threads, I already have it at 10 down / 5 up for each drive. Are you suggesting to be under 10 for both drives collectively? 


I'll try out the read-only use case as well, and provide my findings.


Looking forward to your reply.



Share this post

Link to post
Share on other sites
  • 0

Hi Chris, 


So just a quick update on this thread.


It seems the problems have fixed themselves out - not sure why to be honest. I rebooted my Win 2008 server and the problem has not happened again. I'll still keep an eye on it though.


With respect to the read only functionality. It seems that once it's turned on (shared between 2 machines), the read-only functionality automatically applies to both machines. Meaning, I can still upload local content, but the other computer will not see this. I am however able to copy already uploaded data. So I guess perhaps the process would have to include converting back and forth between a read-only and read/write whenever I want to transfer media between machines using the same cloud drive.


I was hoping I could upload media to my local account, and have my VPS read the content in Read-Only format, and have that work as a seamless workflow.


Is this doable? 



Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...