Jump to content
  • 0

File Ownership Disaster - Overnight Loss of Ownership for Everything in my Drivepool [and only Drivepool]




So, I went to bed last night and everything was working fine (as it has done for a long time). I woke up this morning and found I couldn't put new files into a folder... weird! Let's try another folder... no. Well, to cut a very long story short I cannot:

- Add files to any folder in my drivepool.

- Add new folder to my drivepool.

- Move/Delete/Edit any existing file in my drivepool.


The 'owner' is now a string of random letters and numbers (note, I have made no changes to Windows 10, not changed my account or tried to change any permissions before this issue arose). This only applies to the (95TB) Drivepool, my other drives are all fine - limiting the issue to my Drivepool alone.


I have tried numerous ways to change the ownership 'back' - all fail:

- ...>Security>Advanced (at file, folder, drive, root, mount levels)

- 'takeown' within an elevated command prompt.

- TakeOwnershipPro

- TakeOwnershipEx

- ResetPermission


- All of the above with my standard (admin privalage) account and I've also enabled the default local Administrator account and used that. Neither worked.


The fact that this only applies to the drivepool and affects only files handled by the DrivePool software reasonably leads me to believe this is a consequential factor.


I cannot create a new pool and move the files into it one drive at a time because I don't have "permission".


Can you please help?

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

OK - random! I've restarted the PC seven times so far. Nothing worked. Restart #8 (third restart after the steps above - nothing done to try and fix the issue between restart #6, #7 & #8) and the permissions are back to normal (and I am allowed to change permissions on a file & folder level again). One of those mysterious quirks that has fixed itself.

Link to comment
Share on other sites

  • 0

I had something similar.  One day I woke up and couldn't write to any of the folders.


Eventually I found out that one of the drives dropped off the pool and was disconnected.  I didn't think to check the DP console as I could still see the pool.


After reconnecting the drive (rebooting) it worked again.

Link to comment
Share on other sites

  • 0

My father when trying to access our pool encountered similar issues like this before. At the time, a restart fixed the problem and we all had permission to access the pool again (read was fine, writes weren't allowed).


From there we just considered it a fluke and updated to the latest beta build. Havne't encountered it since.

Link to comment
Share on other sites

  • 0

Yes, make sure that all of the disks are present in the system.  


Otherwise, this is very unusual. 

As for the long string, I'm guessing it looks something like this: 



However, if it was for "S-1-5-32-544", and it was not resolving to a name. .... that's a bit more serious of an issue. 




Either way, this should walk you through resetting the permissions and ownership:



If this doesn't work ..... well... I'd honestly recommend a reinstall, or a restore, as there may be an issue with the system. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...