Jump to content
Covecube Inc.
  • 0
Allineedis

Scanner/Drivepool/HDD help needed

Question

Pulling my hair out, the last few I still have :-).

 

First question.

 

Bought several 8TB drives. In order to have bays available I started to remove several of my 3TB drives.

 

The first went OK an swapped it with the 8TB drive.

 

The second gave an error when removing, due to IO error!? Shortly after the scanner returned 16 unreadable sectors and that this drive was overheating (34 C).

 

Could this be a false positive?

 

There was a lot of IO during the swapping of the drives, maybe the controller choked?

 

Drivepool is currently force removing the drive. Am I doing the right thing or should I first scan the whole disk?

 

Second question.

 

The 3TB drives will be used in a different server an I usually go in to disk management and delete the current volume and create a new simple volume without path and driveletter when moving drives.

 

Apparently I was not paying attention and am now stuck with a 2048 GB drive. I am not seeing a 768 GB unallocated part.

 

Went into diskpart and even there the drive has a max capacity of 2047 GB. tried "clean", "convert to gpt" but no success (diskpart states that it performed requested actions successfully). When listing the volumes it states there are no volumes.

 

With Seatools I only have the Basic checks option (using an external e-sata hot swap bay).

 

I know Drivepool can handle this drive since it was showing as 3TB drive and it worked perfectly for almost 2 years. Currently it does not even recognize the drive.

 

I googled extensivley, but only end up at results that I already have tried.

 

Is there a way to reset a drive to its factory settings?

 

Maybe one of you guys have a trick.

 

Thank you, thank you, thank you...

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

OK, Drivepool solved my 3TB issue. Weird thing happend. I inserted the drive into a different server and it was recoginized right away with the correct size. A bit odd that I had issues with the server where it originated from. I did not restart in that one, so maybe that was the issue.

 

The SMART warnings on the other drive went up (decided for a full scan to see if the first warning would go away).

 

Scanner kicked in and started to evacuate files from that drive, but noticed another weird thing, that Drivepool is actually writing data to the failing drive (Scanner plug-in set to move files out of damaged drives). I watched this behaviour for 20 minutes and decided to resume force removal.

Share this post


Link to post
Share on other sites
  • 0

Do you mean the 3TB drive gave the IO error and SMART error here?

If so, the "unreadable sectors" would definitely be related the IO error (same thing, actually, unreadable sectors on the disk). 

 

What model are these drives? 

 

Also, if you want to test to see if the controller was just getting overloaded, try using the "Burst Test" option in StableBit Scanner. This specifically saturates the drive's bus, and is a good stress test. if you're seeing errors here, then it may indicate a drive, cable or controller related issues.  if you see no tests, then this is an issue with the disk platters or read/write heads (eg, a mechanical issue). 

 

As for the 2048GB drive, was this the 3TB drive? If so... then that is definitely odd.

However, if this was the pool, this is normal, as the pool always shows a set size there, but reports the "proper" size everywhere else. 

 

And for any weird disk issues, rebooting is usually a good solution, as it may refresh the drive info. 

 

 

 

As for the pool placing files on the "bad" drive, are you using any special balancers (such as Ordered File Placement, SSD Optimizer or the like) or using the File Placement rules? 

Share this post


Link to post
Share on other sites
  • 0

Hey drashna, sorry for the delay, but had the flu for a couple of days.

 

The drive actually failed. It was a Seagate Barracuda (ST3000DM001). It eventually hit 250+ unreadable sectors. Funny that the count sometimes went up and down again with 8 sectors. Drive is now removed, sadly lost a few files which could not be repaired. Not a big issue, I just re-rip them from the original disks. Was probably a coincedence that the drive failed at the moment of first removal, which tricked me to believe it was a false positive.

 

I am using several balancing plugins (in that order).

 

Drive usage limiter (set to put only duplicated files on certain drives)

Stablebit scanner (pretty much default settings)

Duplication Space Optimizer

Disk Space Equalizer (equalize by percent all file types)

 

Noticed that the drive usage limiter allows also unduplicated files on drives that are set to only have duplicated files. The server is currently balancing so maybe it will solve itself, but it will take a few days. The server holds 50+ TB of data.

 

Will report back

Share this post


Link to post
Share on other sites
  • 0

I'm sorry to hear about you getting sick, as that is never a pleasant experience. especially when compounded with disk issuse! :(

 

 

As for the varying unreadable sectors, this can happen. A flaky controller can cause this to happen (which a Burst Test can reveal), but so can normal usage. As data is written to the affected sectors, it can fix the issue. However, the ST3000DM001 model is known to have issues, and if you're experiencing issues with them, I'd recommend replacing the drive, period.  Especially if you see the "Current Pending Sector Count" or "Uncorrectable Sector Count" SMART warnings for the drive (as this indicates that it is failing). 

 

 

 

As for the balancers, keep in mind that the order that they're set in does have meaning. This is the order of priority, and that can affect how the balancers work and how files are placed. 

 

Also, with the Disk Space Equalizer balancer, once the pool is equalized, I'd recommend disabling it, as the pool should automatically do this (well, it places files on the disk with the most (absolute) free space).

Share this post


Link to post
Share on other sites
  • 0

So, after several days of duplicating and balancing all is back to normal again.

 

Just to double check. I use the disk space equalizer plugin to equally distribute files by percentage. Drivepool has finished this process now. Am I OK by disabling all plugins and leave the distribution to Drivepool? Only plugin I would leave active is the Scanner plugin.

Share this post


Link to post
Share on other sites
  • 0

Glad to hear it.

 

As for the balancers, I'd disable the Disk Space Equalizer balancer, as it can cause a lot of activity. But I would recommend leaving the rest alone (the default five) as these should be fine, and a couple are there to help prevent certain issues (such as overfilling disks). 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...