Jump to content
Covecube Inc.
  • 0
Spotta

no pool access after OS re-install

Question

I started using Drivepool around a month ago, gave it a good trial, moved my pool to another machine with no problems and bought the bundle.

I recommended it to a friend of mine and around two weeks ago we upgraded his main drive to a SSD and pooled all his hdds as I had done mine.

The clone of his OS introduced some issues so yesterday we disconnected all the hdds, did a clean install of Win 7, connected back up the hdds and installed the drivepool trial again. Drive pool saw all the drives, the pool is as it was before, but in Win Explorer its blank and gives A 'you dont currently have permission to access this folder'.

Under Drive Mgmt it shows as a 2047.97Gb GUID partition.

 

Is it safe to click continue to permanently get access to this folder?

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

If the specific issue is that you no longer have permissions to access the pool after reinstallination, then it sounds like this is a NTFS permissions issue with the pool.

 

You should be safe to click "Continue". Otherwise, you may want to reset the permissions on the pool.

To do so, either:

  • download the "WSS Troubleshooter utility", run it on the system and select the "Reset NTFS permissions on the pool" option.
    http://dl.covecube.com/WssTroubleshoot/Release/download/Wss.Troubleshoot_1.0.0.165.exe
    or,
  • Right click on the Pool drive in Explorer (in "Computer"). Select "Properties", and open the "Security" tab. 
    In the "Security" tab, click the "Advanced" button at the bottom of the window. 
    Go to the "Owner" tab, click "Edit" and select "Administrators", and check the 'Replace Owner on Subcontainers and objects" option.  
    Hit "Ok". This may take a while to complete (the more files you have, the longer this will take). And it will warn you about re-opening the window (you can skip that, but you may want to).
    Go to the "Permissions" page.  Click on the "Change Permissions" button.
    You want to make sure that "Administrators" and "SYSTEM" have full control.  You will want to add "Users" here as well, (read+execute), and whichever other user accounts, as needed. 
    Check the "Replace all child object permissions with inheritable permissions from this object".
    Click "OK", and let this run. This may take ... a few hours, depending on the size and content of your pool (the more files you have, the longer this will take). 

 

Once you've done this, you should be able to access everything properly.

 

Also, to emphasize, the "SYSTEM" account ABSOLUTELY MUST have full control. There are a number of system processes that require this, and ... well, so does StableBit DrivePool, to be able to balance and duplicate the data properly. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...