Jump to content
  • 0

Ordered File Placement - Observations (and Advice?)


jmone
 Share

Question

It sure it will be my config or understanding of how it works, but I can't seem to get Ordered File Placement working as I expect to:

- Fill Drive 1, then 2 then 3 etc (in a specified order with the Seagate 8TB HDD to be filled first)

- Exclude three directories from being placed on the Seagate 8TB HDD (Video Editing, TV Recordings, X Drive) 

 

Observation 1: What I'm seeing is a loop moving the same set of files around:

1) Manually kick off Balancing and DrivePool seems to be scanning the drives, then will

2) start moving some of the files in "Video Editing, TV Recordings, X Drive" from the almost full 4TB HDDs (eg drive 64f07) to the most empty one (drive 66882).  Note: Drive 64F07 is placed higher than 66882 on the "File placement priority".  Both Drives are selected as a "File Placement Option".

3) From time to time , DrivePool stops moving files and does a "Building Bucket Lists" that appears to be rescanning the pool

4) Here is the odd part, DrivePool will then either:

    - start moving these same files BACK to the drive they came from, or

    - will complete balancing with a "File Distribution not Optimal" but will move these same files BACK to the drive they came from the next time I kick of Balancing.

 

Now these are just my observation over the last week testing out DrivePool and it could be that as the content on the HDD were ordered differently to what DrivePool likes.  Each pass is certainly quicker and moves less files than the one prior to it, so it may eventually be "Happy" but I've not yet reached that point.  To complicate matters I'm also adding files from time to time.  

 

Q: Does it take many (instead of a single) Balancing Pass to get the order to how the Balancer wants it? 

 

Observation 2: When I add new items to the Pool, they are normally added to the highest drive listed drive in "File Placement Priority" with free space - perfect!  However, if the pool is in the middle of a balance operation they are instead added to the drive with the most space (eg the one on the bottom of the "File Placement Priority" list) and the next balancer pass then moves them.  

 

Q: I presume this is normal?

 

Observation 3: I've had the Balancer just stop on occasions and it seems to be related to when I'm using another PC on the network to access the media on the pool (as it was an item I'd just added the balancer may have been moving that file).  It took a long time for my client PC to open the media (say 1min instead of a couple of seconds) and after watching the show and returning to the PC Running DrivePool, the balancer had stopped when it still had hour to go.  

 

Q: I presume this is normal?

 

 

 

Also, I've attached the screen shots of my settings so any suggestions is welcome!

 

Thanks

Nathan

post-2289-0-83956900-1452291726_thumb.jpg

post-2289-0-91537200-1452291730_thumb.jpg

post-2289-0-62613000-1452291740_thumb.jpg

post-2289-0-82544600-1452291744_thumb.jpg

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Yeah not getting it.  Kicked off another Balancing (post a re-measure) and it immediately started moving some Video Editing files ("moving files based on pattern rules...") off one of my almost full 4TB drives that the balancer had previously filled up, to the almost Empty one.  - It moved about 224GB

 

EDIT: When that finished - I did another Balancing (did not a re-meaure) and.... it is now moving the files back off this drive

 

Thanks

Nathan

Link to comment
Share on other sites

  • 0

FYI - I'm now trying the "SSD Optimizer" as when trying to create a MKV, I got an error from MakeMKV saying "OS Error - An operation failed because the disk was full.  It this is a thinly provisioned volume the physical storage backing this volume as been exhausted".  In looking at Resouce Mgr, the MKV was being written to an "almost full" disk.

 

In SSD Optimiser, I've set my order of the Disks with only one of my 7K HDS disks set as the "SSD".

Link to comment
Share on other sites

  • 0

Sorry to the delay in responding. 

 

A couple of things... 

On the "Settings" page of the balancer settings, try setting the ratio to "100%" as this may more aggressively balance the data.

 

As for the file placement rules, change the option to "never allow placement on other drives".

 

 

And if you're running the 659 beta, could you run "dpcmd check-pool-fileparts X:\ 2 > drivepool.log" and upload it using the following link:

http://wiki.covecube.com/StableBit_DrivePool_2.x_Log_Collection

(there should be a Box.com upload widget at the bottom of the page, and this supports large uploads).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...