Jump to content
Covecube Inc.
  • 0

Possible bug with VMWare Player


Question

I don't plan on using a CloudDrive disk in this way - too many things to go wrong - but it does appear that the virtual disk is seen differently to a physical disk by VMware Player. Not sure if this is a Player issue or CloudDrive issue.

 

* Create a virtual disk in CloudDrive (say 20GB), but don't format

* Create new VM in Vmware Player

* Add the CloudDrive disk as an exisiting physical disk to the new VM
* The disk appears as a 2.5GB disk

 

Also when adding a pre-partitioned and formatted CloudDrive as a physical disk, existing partitions aren't listed like they would be on a real disk.

 

Possibly relevant stuff:
Windows 8.1 x64

VMWare Player 7.1.2

Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

I've let Alex know (as he has VMWare installed already). 

 

Most likely, this is a disk enumeration issue.

 

However, just in case, could you post step by step instructions of what you did (they don't have to be detailed).

And if you do, could you enable logging, as well:

http://wiki.covecube.com/StableBit_CloudDrive_Log_Collection

Link to post
Share on other sites
  • 0

Sure.

  • Create a new cloud drive (I'm using Amazon Cloud Drive)
  • Leave everything as default (10GB drive etc). I enabled encryption, though not sure if this is relevant. Format drive + assign drive letter
  • Create a new VM in VMWare Player (might be slightly different in Workstation or other VMWare stuff)
  • Select - install OS later
  • Select Linux / Ubuntu x64 (not sure if this is relevant, but its what I selected)
  • Set VM location - set to a local physical disk
  • Use default disk settings, then click Finish
  • Edit the VM settings and remove the HDD
  • Add - Hard Disk - SCSI - Use a physical disk
  • Select the virtual drive in the dropdown - name correlates to disk # in disk management
  • Either (a) Choose 'use individual partitions'. Assuming the virtual drive was formatted in step 2, no partitions will be listed - its expected that a single 10GB NTFS partition should be there.
  • Or (B) Choose to use the entire disk, then save the .vmdk. The disk will appear as 1.3GB in the VM settings rather than 10GB as expected. Also, if the drive is set to 20GB in step 2, it will appear as a 2.5GB drive.
Link to post
Share on other sites
  • 0

Thanks. 

I've flagged the files for Alex, and he'll take a look at them soon.

 

 

And specifically, we suspect that it's some sort of SCSI command that is being sent to the disk that we're not responding to properly.  Hopefully, identifying and fixing the issue is simple enough (though, it rarely is). 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...