Jump to content
  • 0

switching 2 x from WHS 2011 to WSE12R2



I got 2 HP N54L MicroServers running both WHS 2011 and Stablebit DrivePool and Scanner,

thinking of switching to WSE12R2.

first starting with 1 server and perhaps later the second server.

but what i wonder will it give issues having 2 servers running WSE12R2 beeing that it runs as domain ?


i once tried WSE12R2 but didn't like the domain stuff and had some issues with the share parts.

(WHS 2011 is much easier and faster setup with setting up shares.)

but perhaps i should give it another try and try out the domain stuff.


also when switching should i first disable the license or can i switch without any issue ?

Link to comment
Share on other sites

10 answers to this question

Recommended Posts

  • 0

As for the two WSE systems?  It depends on how you configure them.  If you're going to skip the domain stuff, there should be absolutely no issue with doing so. I run ... multiple instances of WSE on my network without any issues, if that helps.


As for running it without the domain stuff, check out this link:




And yes, you should deactivate the licenses prior to reinstalling:


  • StableBit DrivePool 1.X: Open the Dashboard (either remotely or locally), and click on the "Settings" button in the dashboard (top, right section). Open the "DrivePool" section in the Settings window, and click on the "manage license" link at the bottom of the page.
  • StableBit DrivePool 2.X: Open the UI on the system that DrivePool is installed on, click on the "Gear" icon in the top, right corner and select the "manage license" option.
  • StableBit Scanner: Open the UI on the system that Scanner is installed on. Click on "Settings" and select "Scanner Settings". Open the "Licensing" tab, and click on the "Manage license" link.
This will open a window that shows you the Activation ID, as well as a big button to "Deactivate" the license. Once you've done this, you can activate the license on a new system.
Link to comment
Share on other sites

  • 0

If setting up the domain would it be smart to use the same name as I use with the others as workgroup ?

So workgroup would be for example "myworkgroupname"

Should I choose "myworkgroupname" as domain ?

I want to use the server mainly as file server for my media.

Mysql db for my shared Kodi db.

And some mono, python programs I run.

Link to comment
Share on other sites

  • 0

After fooling around with 1 whs2011(server 1) and 1 wse2012r2(server 2) I decided to get a bigger server and switch completely over to wse2012r2(server 3).

And sell server 1 and 2 and just run 1 big server.

But here starts the issue when installing the new server with wse2012r2.


Because I already have one running with the name of my workgroup I need to choose another domain name.

When doing so server 2 doesn't show up in the network shares of the new server 3.

Had to change all kind of stuff to make it show up.

Also I somehow getting issues when I want to install .msi files.

Something with permission.

Wonder if it's because both run a domain.

I want to keep server 2 running till I got server 3 completely installed and transfer then the harddrives over with the data and add recover the pool.

Am I doing something wrong ?

Is there a way to set server 3 to the same domain name as my workgroup to make it easier to share the files ?

Link to comment
Share on other sites

  • 0

Well, if you don't mind complex .....


Do a properly migration. This will get user accounts and domain settings.


This is the only way to properly share the workgroup/domain name between two domain controllers. But as I said, it's more complex.


Otherwise, turn server 2 off, set up server 3 completely, turn server 2 back on (you *may* have issues still). 


Or, map the shares, and using the IP address directly.  And use "WORKGROUP-NAME\user-name" for the username when mapping the drive, and use the destination server's info.



As for the MSI files, that's ... odd. There shouldn't be any issues.  I run them all the time on my domain controller (WS2012R2 Essentials) without any issues, and I try to change as few settings as possible.  Worst case, use a command line and "msiexec /a filename.msi" to launch the files. This should elevate them automatically. 

Link to comment
Share on other sites

  • 0

Well after 4 re-installs

I just decided to create a new domain.

The issue with the .msi file seems to be just that one file.

(Install for curl).

Other .msi files just works :s

So the re-installs weren't needed.

Tomorrow I will just remove the drives from the old server and put them in my new server.

And hope drivepool will recognize it.

And rebuild the pool.

Thnx for all the help and info.

Link to comment
Share on other sites

  • 0

Well, that's really odd about the CURL installer.  Should definitely contact the dev about it, or see if they have a FAQ page about it.



And physically moving the drives is probably the simplest solution here.  And yes, the new system will pick up the pooled disks, and automatically recreate the pool on the new system. As long as StableBit DrivePool is installed, that is. :)



And you're very welcome.  If you have any more questions, don't hesitate to ask.

Link to comment
Share on other sites

  • 0

The move went easy and fast,

After test driving everything and editing my mysql database for the shared Kodi installations.

So I thought everything was good to go.

Later this evening I checked the event log,

Noticing some weird errors with the GPO and DNS.(gpt.ini or something like that)

When looking into the GPO I noticed that my own newly created domain there was gone.

I'm sure it worked before because I changed the password policies there.

Also noticed that after a reboot the NFS Server service goes into a suspended state.

Only what work is force it to resume.

So it seems something is still messed up.

Perhaps because there where 2 WSE 2012R2 running.

Looks like I need to do another reinstall next weekend :(

Link to comment
Share on other sites

  • 0

Hmm did a reboot yesterday,

Went to bed.

This morning RDP from my phone into the server,

And noticed the GPO was working again.

Perhaps it recreated it not sure.

When I get home from work I will give it another reboot and hope the NFS Server will start normal.

Link to comment
Share on other sites

  • 0

it's possible that the other server was still online when the new one booted.  Or that something didn't start right on it, I'm not sure.


The Event Viewer would be where to look for that sort of information. The "System" section specifically. And you can filter for errors and critical errors.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...