Jump to content
  • 0

Drive size wrong in Scanner, correct everywhere else



Hi, I love Scanner and DrivePool and I have nothing but good things to say about them to anyone who asks, but this problem is a bad one and I need help.

A couple months ago after running perfectly for at least six months on a new build, Scanner started reporting the size of one disk out of my four disk pool incorrectly (reported 10.9TiB when actually 9.1TiB). Both DP and Windows 10 x64 reported the correct size. I might have left it this way, since it didn't seem to cause any actual problems, but then Scanner tried to run a regular surface scan on that disk and immediately found unreadable blocks. I surmised it was trying to read blocks that didn't exist.

To fix the situation, I went to Scanner's advanced settings and clicked the "Reset settings..." button. This worked! All drive sizes were then correct, and all drives passed their surface scans. DP and Windows still showed the correct information.

BUT then I restarted the machine. When it came up, 2 of the 4 drives, one of which was the original misreported disk, had lost their partitions completely. After a lengthy restore from backup, finally everything seemed in order - all drives were the correct size, no errors during scanning.

And that's the way things stayed through many restarts for at least the last several weeks, but now after the most recent restart the original issue has popped up again. The same 10TB disk is again being reported as a 12TB disk in Scanner while DP and Windows report it correctly. I haven't tried to scan it - in fact I've disabled automatic scanning for that drive.

I'm sure this has something to do with the fact that I'm using two USB enclosures for these drives - 2 drives per enclosure. One enclosure has a 12TB and a 4TB, the other has a 12TB and the misreported 10TB. (I imagine this would never have been an issue if I were using a pair of identically sized drives for each enclosure.) It's just so strange that Scanner would be the only place the problem shows up. I'm currently running, but the issue first arose with the last stable release, whatever that version number was.

Please if there is any way to correct this problem without ending up in another 48 hour rebuild, I would appreciate any advice. For now I just have to live without scanning that particular drive.

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

No I have definitely not opened a ticket.

The misreported drive is a WD100EFAX. It shares the enclosure with a WD121KRYZ.

The enclosure - which is technically more of a docking station - is a Wavlink ST334U.

I've been on the latest stable release of Scanner - since shortly after it was posted, I believe. The issue first appeared with the last stable release. I have never installed a beta or release candidate version of Scanner.

Link to comment
Share on other sites

  • 0

Christopher, I do thank you for responding and offering to help, but instead of drilling down to discover the root cause, I've decided to go ahead and just rearrange things to avoid the problem in the future. I'm going to purchase another 10TB drive to replace the 4TB. I'll put the two 12TB drives in one enclosure, and the two 10TBs in the other. That way Scanner won't have the opportunity to get the sizes mixed up. I'll probably end up restoring 20 or 30 TBs of data from backup, but hey that's what backups are for. :)

Thanks again. And for the record I'm still happy with the Stablebit software. I knew when I got these enclosures they were going to screw things up somehow. They're just too convenient.

Of course if my plan backfires, I'll be back to open that ticket. :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...