Jump to content
Covecube Inc.
  • 0

Drive removal from pool failed, now what?


- Server 2012 R2.
- Stablebit drivepool and scanner.
- Have 3x 3TB WD Red and 3x 4TB WD Red all in a pool.

Am removing all the 3TBs from the pool, started with one and it removed fine (pool is less than a quarter full).  The second stalled at 90.1% and then sat there doing nothing.  Restarted the server, now I get "disk is missing" error for drive "J" even though it is still there.  Restarting drivepool service does nothing.  Tried adding "J" back to the pool and it just sees it as another disk and I can't remove it now with 2 "J"s in the drive pool.

Would appreciate some assistance to get this drive back in the pool to finish cleanly removing.




Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Just a few questions since it's Sunday and you may or may not get an official response today:

  • Can you get info from the "Error details..." link next to the second J: drive?
  • What was the original drive letter of the first drive you removed from the pool (successfully)?
  • Is the J: letter of the drive that won't fully remove from the pool it's correct letter (in the original pool)?
Link to post
Share on other sites
  • 0

Hi Jaga, here are the answers

- Error details just says it cannot remove a disk from the pool while another disk is missing.

- Drive K was the first one removed from the pool, it is currently the only empty 3TB hdd.

- Yes, it has always been J drive.  After the reboot it was sitting in non pooled drives as J and the pooled disks showed J was missing, so I clicked add back to pool and now there are 2 listings for the same J drive.

Link to post
Share on other sites
  • 0

So basically it just failed during removal from the pool (or was interrupted during the reboot), and when the machine came back up Drivepool identified it differently, though still as part of the pool (likely due to the hidden Poolpart-xxxxx folder on it).

Here's what I would do, since the rest of the pool is still intact:

  1. Stop the Drivepool service.
  2. Find the J: drive in Explorer and turn on Show hidden files and folders so you can see the Poolpart-xxxxx folder.
  3. Copy the files/folders that are inside that to another of the Pool's drives (I: might be a good candidate) - make sure they go into the root of the other drive's Poolpart-xxx folder.
  4. If the copy tells you any of them are overwriting existing files, double-check the size/date before confirming/denying so you're sure you aren't overwriting good data.  If file size/date stamps match, you can skip those.
  5. When the copy is done you'll want to then move the files/folders from inside the J: drive's hidden Poolpart-xxxxx folder to it's root folder (i.e. J:\), so they aren't inside the Poolpart folder anymore.  That ensures you still have them as a backup if you need them.
  6. Start the Drivepool service and do a re-measure on the Pool.  It may indicate that J: is now empty and that balancing is off (since you may have had some duplicated files on J:.  That's okay.
  7. See if you can then remove both J: drives from the Pool through the interface.  You can always do a Force Remove if needed.  Start with the 2nd one in the list as you see it now.
  8. If you can't remove or force remove J:, stop the Drivepool service again, navigate to J: in Explorer, and manually delete the now-empty Poolpart-xxxxx folder.
  9. Start up the Drivepool service and program again and see if J: is still listed (either of them).  Try removing/force removing again if needed.

Balancing may be off when you're done removing J:, but that's easily fixed by re-measuring the pool and then doing a manual re-balance.  Only kick that off when you're happy that J: is gone and the rest of the Pool looks okay.

This is just my opinion on steps you can take to correct the problem while preserving files - different people may have different ways to resolve it.

Link to post
Share on other sites
  • 0

Just a quick update, I worked with Stablebit support and was able to remove all three of my 3TB drives from the pool.  Two stalled at around 90% of the removal process, once they hit that I had to do a settings reset in Drivepool, they then showed as removed from the pool.  The issue is 2 of the drives still had data on them in pool folders, thankfully I was able to copy the data back into the pool from those drives.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...