Jump to content
Covecube Inc.
  • Announcements

    • Christopher (Drashna)

      Login issues   11/07/17

      If you have issues with logging in, make sure you use your display name and not the "username" or email.  Or head here for more info.   http://community.covecube.com/index.php?/topic/3252-login-issues/  
    • Christopher (Drashna)

      Getting Help   11/07/17

      If you're experiencing problems with the software, the best way to get ahold of us is to head to https://stablebit.com/Contact, especially if this is a licensing issue.    Issues submitted there are checked first, and handled more aggressively. So, especially if the problem is urgent, please head over there first. 
  • 0
stephanie

Automatic mounting at startup problem.

Question

It takes almost 10minutes to mount the drive.

 

 

0:00:21.2: Information: 0 : [CloudDrives] Synchronizing cloud drives...
0:00:21.4: Information: 0 : [Disks] Updating disks / volumes...
0:01:22.7: Warning: 0 : [PinDiskMetadata] Cloud drive is not found in VDS' basic disks collection.
0:02:22.7: Warning: 0 : [PinDiskMetadata] Cloud drive is not found in VDS' basic disks collection.
0:03:22.7: Warning: 0 : [PinDiskMetadata] Cloud drive is not found in VDS' basic disks collection.
0:04:22.7: Warning: 0 : [PinDiskMetadata] Cloud drive is not found in VDS' basic disks collection.
0:05:22.7: Warning: 0 : [PinDiskMetadata] Cloud drive is not found in VDS' basic disks collection.
0:06:17.5: Information: 0 : [ioManager:29] All writes complete.
0:06:22.7: Warning: 0 : [PinDiskMetadata] Cloud drive is not found in VDS' basic disks collection.
0:07:22.7: Warning: 0 : [PinDiskMetadata] Cloud drive is not found in VDS' basic disks collection.
0:08:22.7: Warning: 0 : [PinDiskMetadata] Cloud drive is not found in VDS' basic disks collection.
0:09:22.7: Warning: 0 : [PinDiskMetadata] Cloud drive is not found in VDS' basic disks collection.
0:09:30.1: Information: 0 : [Disks] Got Volume_Arrive (volume ID: c8f37585-c7a6-41f2-928c-554ffc0ca067, plex ID: 00000000-0000-0000-0000-000000000000, %: 0)...

Share this post


Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 0

Okay.

 

we've been seeing a number of people with issues with the Google Drive/G Suite stuff, as it looks like Google has/is changing things.

 

That said, could you try installing the latest version:

http://dl.covecube.com/CloudDriveWindows/beta/download/StableBit.CloudDrive_1.0.2.906_x64_BETA.exe

 

There are a number of performance fixes, and bug fixes that may help with this issue.

 

If it doesn't, let me know. 

Share this post


Link to post
Share on other sites
  • 0

Latest beta installed. It takes almost 10minutes to be able to mount the drive. It stays stuck on starting service.

 

0:00:15.4: Information: 0 : [Main] Starting user feedback...
0:00:15.4: Information: 0 : [Main] Starting Disks...
0:00:15.5: Information: 0 : [Main] Starting provider registry...
0:00:15.6: Information: 0 : [Main] Starting CloudDrives...
0:00:16.1: Information: 0 : [CloudDrives] Synchronizing cloud drives...
0:00:16.2: Information: 0 : [CloudDrives] Valid encryption key specified for cloud part f62833d5-90de-41f1-a186-e9f3a9464697.
0:00:21.5: Information: 0 : [CloudDrives] Synchronizing cloud drives...
0:00:21.5: Information: 0 : [CloudDrives] Started 1 cloud drives.
0:00:21.5: Information: 0 : [Main] Cleaning up cloud drives...
0:00:21.5: Information: 0 : [CloudDrives] Synchronizing cloud drives...
0:00:21.5: Information: 0 : [ChunkIdSQLiteStorage:4] Cleaning up drives...
0:00:21.5: Information: 0 : [Main] Starting BitLocker...
0:01:21.5: Warning: 0 : [PinDiskMetadata] Cloud drive is not found in VDS' basic disks collection.
0:02:21.5: Warning: 0 : [PinDiskMetadata] Cloud drive is not found in VDS' basic disks collection.
0:03:21.5: Warning: 0 : [PinDiskMetadata] Cloud drive is not found in VDS' basic disks collection.
0:04:21.5: Warning: 0 : [PinDiskMetadata] Cloud drive is not found in VDS' basic disks collection.
0:05:21.5: Warning: 0 : [PinDiskMetadata] Cloud drive is not found in VDS' basic disks collection.
0:06:15.9: Information: 0 : [ioManager:29] All writes complete.
0:06:21.5: Warning: 0 : [PinDiskMetadata] Cloud drive is not found in VDS' basic disks collection.
0:07:21.5: Warning: 0 : [PinDiskMetadata] Cloud drive is not found in VDS' basic disks collection.
0:08:21.5: Warning: 0 : [PinDiskMetadata] Cloud drive is not found in VDS' basic disks collection.
0:09:21.5: Warning: 0 : [PinDiskMetadata] Cloud drive is not found in VDS' basic disks collection.
0:09:26.8: Information: 0 : [Main] Enumerating disks...
0:09:28.2: Information: 0 : [Disks] Updating disks / volumes...
0:09:30.3: Information: 0 : [Disks] Updating disks / volumes...
0:09:38.8: Information: 0 : [Main] Starting disk metadata...
0:09:38.8: Information: 0 : [Main] Updating free space...
0:09:41.5: Information: 0 : [Main] Waiting for cloud drives...
0:09:41.5: Information: 0 : [Main] Service started.
0:10:31.4: Information: 0 : [ioManager:29] All writes complete.

Share this post


Link to post
Share on other sites
  • 0

Well, there are 2-3 issues here.

 

The first is that the service is actually waiting on VDS to load. VDS is the virtual disk service (it says virtual, but it handles all disks).  Something is causing that to take a while to load.

 

Also, it looks like there are a bunch of SD/CF/etc cards arriving (connecting) at the same time.  If you have a bunch of these, it could cause the above issue. (VDS does some weird things when a bunch of disks connect at once).

 

If it's possible to disconnect them, it may be a good idea.

 

 

 

And in the newer logs, there are two things: the JSON settings file ("'C:\ProgramData\StableBit CloudDrive\Service\Settings.json'") is being accessed by another file. It shouldn't be. It really should only be accessed by our software. And it shouldn't be locked, when we read it, IIRC.

 

Also, it looks like the driver for the pool may not be properly installed.

Share this post


Link to post
Share on other sites
  • 0

~ I went into Disk Management, selected the ones i rarely used.  properties, driver, disable (on all of the sd card etc.)

 

~ I use BitDefender Total Security 2018 and Malwarebytes. I've added these to the exclusions lists, just in case.

 

c:\program files\stablebit\clouddrive

c:\programdata\stablebit clouddrive

 

~ I also noticed Malwarebytes blocking a website that StableBit CloudDrive connects to. I added the website into it's exclusions list as well.

 

~ The startup mount is still delayed.

 

-Blocked Website Details-
Malicious Website: 1
, , Blocked, [-1], [-1],0.0.0

-Website Data-
Domain: sawebservice.red-gate.com
IP Address: 52.16.59.228
Port: [2292]
Type: Outbound
File: C:\Program Files\StableBit\CloudDrive\CloudDrive.UI.exe

Share this post


Link to post
Share on other sites
  • 0

Red-Gate is used for error reports, and should also be harmless (well, actually, better than harmless, helpful rather).

 

 

Alex did make a change recently that may help wit hthe json stuff:

http://dl.covecube.com/CloudDriveWindows/beta/download/StableBit.CloudDrive_1.0.2.926_x64_BETA.exe

 

 

Otherwise, I'd recommend doing this:

http://wiki.covecube.com/StableBit_CloudDrive_P0000001

 

And then reinstalling the software. 

 

 

If the issue persists, then let me know. 

Share this post


Link to post
Share on other sites
  • 0

~ I followed that wiki and installed StableBit.CloudDrive_1.0.2.928_x64_BETA.

 

~ I noticed from the service.log a lot of chunk ID lines. Maybe that's why it takes awhile to mount, it's verifying everything? It just seemed weird to me, sometimes it would mount very fast, other times, it would take more/less 10minutes.

 

0:06:39.6: Information: 0 : [ChunkIdSQLiteStorage:16]   chunks IDs: 443,444,445,446,447,448,449,450,451,452,453,454,455,456,457,458,459,460,461,462,463,464,465,466,467,468,469,470,471,472,473,474,475,476,477,478,479,480,481,482,483,484,485,486,487,488,489,490,491,492,493,494,495,496,497,498,499,500,501,502,503,504,505,506,507,508,509,510,511,512,513,514,515,516,517,518,519,520,521,522,523,524,525,526,527,528,529,530,531,532,533,534,535,536,537,538,539,540,541,542
0:06:39.6: Information: 0 : [ChunkIdSQLiteStorage:16]   chunks IDs: 343,344,345,346,347,348,349,350,351,352,353,354,355,356,357,358,359,360,361,362,363,364,365,366,367,368,369,370,371,372,373,374,375,376,377,378,379,380,381,382,383,384,385,386,387,388,389,390,391,392,393,394,395,396,397,398,399,400,401,402,403,404,405,406,407,408,409,410,411,412,413,414,415,416,417,418,419,420,421,422,423,424,425,426,427,428,429,430,431,432,433,434,435,436,437,438,439,440,441,442
0:06:39.6: Information: 0 : [ChunkIdSQLiteStorage:16]   chunks IDs: 340,341,342
0:06:39.6: Information: 0 : [ChunkIdSQLiteStorage:16] Set all chunks enumerated 'True'...
0:06:44.0: Warning: 0 : [ChunkIdHelper:16] Checking for duplicate chunks...
0:06:44.5: Information: 0 : [Disks] Got Pack_Arrive (pack ID: c3fca92b-c7fc-4190-96f7-4611b1db1b79)...
0:06:44.5: Information: 0 : [Disks] Got Disk_Arrive (disk ID: 1a65cda5-365e-460c-b1f8-52de932fcded)...
0:06:45.2: Information: 0 : [CloudDrives] Synchronizing cloud drives...
0:06:45.2: Information: 0 : [CloudDrives] Started 1 cloud drives.
0:06:45.2: Information: 0 : [Main] Waiting for cloud drives...
0:06:45.2: Information: 0 : [CloudDrives] Synchronizing cloud drives...
0:06:45.2: Information: 0 : [Main] All cloud drives ready.
0:06:45.5: Information: 0 : [Disks] Updating disks / volumes...
0:06:50.2: Information: 0 : [Disks] Got Volume_Arrive (volume ID: 3e4f340c-2a9e-46fd-bb89-5abdcbb08b82, plex ID: 00000000-0000-0000-0000-000000000000, %: 0)...
0:06:50.2: Information: 0 : [Disks] Got drive letter assign (volume ID: 3e4f340c-2a9e-46fd-bb89-5abdcbb08b82)...
0:06:52.9: Information: 0 : [Disks] Updating disks / volumes...
0:07:43.1: Information: 0 : [ioManager:27] All writes complete.

Share this post


Link to post
Share on other sites
  • 0

The Chunk ID stuff is indexing the contents on the provider.  This is so that we have a definitive list of the files.  This is to both reduce the API load on the providers, as well as prevent issues (namely, we had an issue where the file lists weren't coming back reliably, and we ended up writing partial chunks of data rather than full files).  

 

So, if the chunk ID database gets corrupted/lost/reset, it will do this.  

 

So, the above instructions will cause this to occur. At least, for the first time mounting the drive after doing this.

Share this post


Link to post
Share on other sites
  • 0

Okay.  It definitely shouldn't be doing that. 

 

If you could, enable boot logging and reboot:

http://wiki.covecube.com/StableBit_CloudDrive_Boot_Time_Drive_Tracing

 

This may capture what is going on here.

 

 

But honestly, given all the issues:

 

If you haven't uninstalled and reinstalled stableBit CloudDrive, I would recommend doing so now.  

It is possible that this may help.

 

If you have, then ... it may be worth reinstalling the system. Given some of the other issues we've seen here, it is possible that there is an issue with the installation. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×