Jump to content
  • 0

Drive is being labeled disconnected, but still shows up in explorer, reboot corrects it


Josh
 Share

Question

I have 5 drives in an enclosure that are in a pool. One drive has intermittently been being alerted as disconnected from the pool (it is usually the same drive). However, HD Sentinel, windows explorer and stablebit scanner, all still report the drive as live, healthy and accessible. I can open up/navigate the poolpart folder on the disk that drivepool says missing.

Drivepool gives me both the option to remove the "missing" drive, but it also shows up in the list of drives that are non-pooled that I can add. However, if I either just try to add the drive back without removing the "missing" listing, or remove it (which visually at least looks successful), then try to add it, both report the error that I "cannot add a disk to the same pool twice". I've also tried the reset settings option, but it still shows as missing once drivepool starts back up.

The only resolution I've found is to restart the computer (the drive is then listed as being back in the pool, even if I had attempted the "remove" operation before the restart), but this is a hassle and messes up anyone currently accessing files (it is a HTPC server).

Hopefully there is a resolution besides constantly restarting the computer to be found.

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

I have had similar problems. Sometimes it's just a bad cable, sometimes it was an old drive starting to fail, sometimes the multi HDD enclosure was failing. If your enclosure fan is not keeping enough air flow, then it could be that your drive(s) are getting too hot and randomly disconnecting.

Another time I had an issue with more than one PoolPart on a HDD, and that caused all kinds of weird errors. I solved that issue by tansferring all the files off that HDD and giving it a low level format, wiping out everything, and then added it back to DrivePool.

I am currently dealing with an issue where I have a USB 3.0 HDD that is overheating on extended writes. I switched that HDD to a USB 2.0 port, with much lower write speeds, and that HDD is no longer overheating. I don't know if it's the HDD drive overheating, or the enclosure is getting too hot. In either case, I've ordered a replacement USB HDD for DrivePool and will use the old USB HDD as a file backup to go into storage.

Most of the time DrivePool behaves as it should, but when you have a problem, it sometimes takes a good bit of trial and error to find the cause. Of course, intermittent problems seem to be the worst to troubleshoot. Good luck.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...