Jump to content
Covecube Inc.
  • 0

WHS 2011 DrivePool v1 to v2 Upgrade Trauma


Question

I posted some of this story as a response to a request for guidance from JeffZ as to whether or not to upgrade v1 Drivepool to v2 on WHS 2011 was advisable or not. Drashna has suggested that I open a new thread to air all the issues I ran into:

 

posted 24/10

 

My advice right now is DON'T DO IT!

 

I reinstalled my four Drivepool v1 data disks on a WHS 2011 reinstall on a new server two months ago and it went really well and smoothly. I was really impressed and wrote to this forum saying so. I was assured that upgrading to Drivepool v2 would be just as easy - tonight I found otherwise. The installation seemed to go well - un-installed v1, rebooted installed and activated v2 and rebooted. All the folders were back in place on the server and all seemed well however:

1. No access to any shares from the network

2. WHS 2011 Dashboard Server Folders and Hard Drives showed nothing but "Refreshing list of items.." ad nauseum.

3. After giving system time for Drivepool to check and rebalance pool still no change in 2 so ran Drivepool Troubleshooter - Restore Drivepool shares - no change!

4. Ran Drivepool Troubleshooter - Reset NTFS permissions on pool. This ran very slowly for a long time then came up with error saying unable to complete.

 

I'm really disappointed and stressed out about this. The server is working fine, the folders are all in place (apparently) but the network sharing is completely messed up - no users, folders or disk show in WHS 2011 Dashboard and I get errors if I try to find or insert any and I really don't know what to do next. I'd really appreciate some help ASAP.

 

I'm afraid I don't understand the ins and out about where the information about file sharing is stored to answer the following: If I reinstate an image of the WHS 2011 OS with Drivepool v1 partition back will this return the system completely as it was or have I messed up data on the data disk shares in a way that I'll just compound the problems further.

 

Why oh why don't I learn - if it ain't bust don't fix it!!

 

posted 25 Oct (but appears to have gone missing):

 

Well I decided that v2 Drivepool had no future on my system, especially when I found that trying to get remote access to Drivepool on my server messed up the firewall on my main client computer with ESET Smart Security! Things just kept getting worse and worse.. I uninstalled Drivepool v2 from client and server rebooted but found that Drivepool v1 would not reinstall on the server - kept getting a message about not being able to contact service but not clear if this "service" was supposed to be on my server or Covecube's - internet connection was fine. At this point, despite my reservations above about the file sharing mismatch I felt I had no option but to reinstate an earlier WHS 2011 OS partition image and try to get back to how things were before this disastrous upgrade. Rebooting after the image recovery gave me a working WHS Dashboard with Users, folders and Disks fully reinstated however sharing was still a mess. I ran "Drivepool Troubleshooter - Restore Drivepool shares" overnight and this time is completed - network shares became available again on the network. There is an ongoing discrepancy between the "shares" as described in the WHS Dashboard Users and Folders and the ServerFolders subfolder properties. I have reinstated the shares to their original status by manually inserting the required permissions in the ServerFolders subfolder properties - the Dashboard methods no longer works reliably but I can live with that so long as the result is what I want and is secure!!.The recovered OS image was a few weeks old, updating with MS Windows update went smoothly with no issues.

 

Thought for the day 26 Oct

 

One further, hopefully last, footnote to this saga to help make sense of it. The trigger to attempting to update to Drivepool v2 was that on 24 Oct, when I tried to open WHS 2011 Dashboard via Remote Desktop, I got error messages indicating that the Drivepool add-in was slowing down the launch of WHS Dashboard. I misguidedly thought that this was a hint that it was time to move to v2 and thus began my disastrous upgrade. What didn't register at the time was that this Dashboard error came after updating the server nVidia Graphics card drivers to 331.58 on 23 Oct. See above for the problems I got into and how I eventually sorted them. The day after I'd recovered the system using the OS partition image, in order to put my server completely back to its position just prior to the attempted upgrade, I proceeded to update the NIC and graphics card drivers and rebooted the server. And guess what? Using Remote Desktop to WHS 2011, on trying to open WHS Dashboard, I got a complete dashboard lock-up, and all network shares inaccessible from LAN. Oh boy, here we go again, and this time with my previously bombproof Drivepool v1! However, this time it was much more obvious that the nVidia drivers were implicated so I performed a clean reinstall of an older nVidia driver. Problem solved.
 
So in conclusion. My system now appears to be working as before, albeit with server share management messier that I would like. I need to do more checks to see that shares are robust and I must get used to the idea that I need to manage them by directly interacting via ServerFolders/subfolder properties sharing permissions etc. rather than through WHS Dashboard. I would strongly recommend that if anyone has a satisfactorily working WHS 2011 Drivepool v1 system - LEAVE IT ALONE, Don't attempt this upgrade. If it ain't bust don't fix it - and, for me, that now includes being very cautious about hardware drivers.
 
Sorry that I've gone on in such detail but if this story prevents a single person from having the problems and sleepless nights I've just gone through then it's been worth it.
 
Chip
 

 

 

 

 

Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...