Jump to content

Pafegori

Members
  • Posts

    7
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by Pafegori

  1. Hi! I don't have a question, but a solution to a problem I encounted. I encounted the following issue for a few files (10s out of a million files) 11:11:11.1: Warning: 0 : [FileDuplication] Error checking file for duplication consistency or duplicating file \\?\GLOBALROOT\Device\HarddiskVolumeXX\<...>. Zugriff verweigert "Zugriff verweigert" is "access denied" localized. It took me a while to figure out what caused it. In my case there are three conditions to trigger it: have 2 duplicated files with a different file modification time the difference in file mod time has to be greater than 60 seconds the file must be read-only (not by ACL, just the normal file system flag) To solve it I just temporarily removed the read-only flag. My suggestion for the drivepool software: Either improve the error message to include the real reason for the duplication error (in the UI and the log) Or ignore the read-only flag and temporarily remove it before aligning the modification dates
  2. Thanks for your reply. This is indeed bad and will confuse (or at least drastically reduce performance) of my backup software.
  3. Hi, is it possible to get more information on this? I still get changing file indices and I would like to know how these are created by DrivePool and in which situtations they can change.
  4. I am using some self-written Python scripts with `os.stat` which on Windows uses `GetFileInformationByHandle` to get `nFileIndexHigh` and `nFileIndexLow`. How does drivepool create these values? If it passes through the original values, which ones takes priority if there are more than 1 copy?
  5. Hi, I am using a software which identifies files by it's unique file id/inode. I have been recording file id changes of files in my pool over the last year and noticed that the file id changes every few weeks or so (around 20 times duing the last year) for files which I didn't (manually) copy/move. I could imagine that a balancing move changes it, but that shouldn't happen that often in my setup. Could you shed some light on how these files ids are created in the first place and what's the reason for changes. Thank you!
  6. Hi, I am currently using a raid5 hardware box which i have encrypted with truecrypt. The read/write speed is perfect, but the hardware is not very reliable. I want to replace that with an jbod box and clouddrive for encryption and drivepool, well for pooling. because I want single disks to still be usable on their own, I intent to create a encrypted "clouddrive" with local disk provider on every disk and then pool them. But I am concerned about the many layers. I have an file based system (pool) on top of an block level device (cloud) on top of a standard file system again on block level harddrive. I would be great if coulddrive could be used like truecrypt for providers which support block level access (like local disk) Then there would be one layer less inbetween. Is my concern justified or would the performance difference be minimal? (I have not yet bought the jbod box, so I cannot run a comparison). Thanks
  7. I have similar problems. 1. I created a disk on the local disk with cache size: None. But I still have to choose a cache dir. The data junks reside in the "StableBit CloudDrive Data ([...])" folder on one hdd, and the cache in "CloudPart.[...]". There are no files on the new disk. The data folder is 10GB (the size of the disk), which I understand must be preallocated BUT the cache dir is also 10GB. Why is there a cache at all for a local disk. 2. Dropbox 2GB disk, cache dir is 1gb according to settings. but cache is 2gb on hdd.
×
×
  • Create New...