Jump to content
Covecube Inc.
  • 0
waltwhitman6969

DrivePool Balancing Taking Forever

Question

Hi Guys,

 

New user here. Here's what I'm working with

(2) 5 TB Hard Drives

1 - 3.75 TB used of 4.55 TB

1 - 500 GB used of 4.55 TB

 

When I first made the pool, nothing balanced and I had turned off my computer after this

Upon turning my PC back on, automatic balancing started and now random files are getting placed onto the drive with more free space. And the percentage complete of the balancing is taking a looooooong time.   Basically .1 percent every 7-10 mins. 

 

Is this by design? Why didn't it balance when I first created the pool? Do I just have to wait for it which seems like it will take some time? What happens when I add a new drive? Same thing? 

Also, I have a large movies folder and for some reason it looks like it is moving the actual movie folder but also leaving an empty folder on the drive the movie was originally on.

 

Any help would be appreciated. I know this seems like a rant. Just new to it all really.

 

 

UPDATE

It finally finished. Took around 17 hours. :\

The issue with the movies folder still stands. Here's an example

Folder: Drive (2011) - Movie inside of this folder. Originally on Drive #1

When the balancer started running it copied this entire folder and moved it to Drive #2 but.......it left the folder Drive (2011) with no movie inside of it on Drive #1.

It did this to multiple other movies as well.

 

I'm assuming this is all by design but it's just super weird to have a wasted folder with nothing in it.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

The balancing can take forever.  Even under ideal situations, it would be roughly 4 hours to transfer 1TB of data.  

And if the system is active, it can take much longer, as balancing cedes priority to other operations. 

 

As for the placement, that's normal.  It's so that the drives have roughly equal usage, over time. 

Share this post


Link to post
Share on other sites
  • 0
On 3/10/2019 at 2:23 PM, Christopher (Drashna) said:

The balancing can take forever.  Even under ideal situations, it would be roughly 4 hours to transfer 1TB of data.  

And if the system is active, it can take much longer, as balancing cedes priority to other operations. 

 

As for the placement, that's normal.  It's so that the drives have roughly equal usage, over time. 

Hi Chris, thanks for the reply. Do you know if it should be leaving an empty folder on the drive it moved stuff from? For example what I had in the original post.

 

Folder: Drive (2011) - Movie inside of this folder. Originally on Drive #1

When the balancer started running it copied this entire folder and moved it to Drive #2 but.......it left the folder Drive (2011) with no movie inside of it on Drive #1.

It did this to multiple other movies as well.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...