Jump to content
Covecube Inc.
  • 0
RobFranklin

SSD Optimizer disregarding file placement rules

Question

Hello All,

Hoping for some help as I've been fighting this problem for literally days now. First of all, the specs:

Windows 10 x64 1809

DrivePool 2.2.2.934

4x 1TB Spinning Disks

1x 3TB Spinning Disk

1x 1TB Samsung 860 Evo

Currently Runnning the StableBit Scanner First, SSD Optimizer Second, Disk Space Equalizer Third and Prevent Drive Overfill Fourth. I have Immediate Balancing enabled, not more often than every Hour, or if more than 10GB needs to be moved, with plug-ins allowed to force immediate balancing(in case a drive throws a smart error, some of the 1TB drives are OLD). I've unchecked "File placement rules respect real-time file placement limits set by the balancing plug-ins" and have "Balancing Plug-ins respect file placement rules" and unchecked "Unless the drive is being emptied."

 I have set file placement rules to put regularly used, and game files on the SSD only, and have selected "Never allow files to be placed on any other disks." But the balancers put the files onto the SSD, then take them back off when I force a re-balance. I'm moving around 200GB of files, so it's not fast. I'm not sure how to convince the SSD optimizer to stop dumping these files off to spinning disks at this point.

Some of the files are program files, as I have a 256GB NVMe SSD for my boot drive that I only put the absolute most critical programs and files on to keep it from filling up, or exceeding writes. I can create a dynamic link from the drivepool location to the native partition on the SSD and bypass drivepool entirely for these files, but I like having control for everything in one console.

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

You need to re-enable the "Balancing  Plug -ins respect  file placement  rules" option. 

Having this disabled means that the SSD Optimizer balancer is ignoring the File Placement rules you have set, and will use the SSD. 

Specifically, you want: 

  • UNCHECK "File placement rules respect real-time file placement limits set by the balancing plug-ins."
  • CHECK "Balancing plug-ins respect file placement rules."
  • UNCHECK "Unless the drive is being emptied."
     

Share this post


Link to post
Share on other sites
  • 0

Post was poorly worded in the most critical section, apologies. Those are the settings I'm using.

After removing all file placement rules, resetting balancers to default, and re-instating the file placement rules, then setting the balancer priorities and settings, it's finally leaving the files in place on the drive, but always shows file distribution is not optimal, somewhere around 90%, and the arrows show it wants to move the data back onto the other drives, but it doesn't through automated or manual balancing. Also, the drives are no longer even close to evenly distributed for data, where they were prior to moving the data back off.balancers3.thumb.JPG.458fb8eb04222a8d52d3f1d9d2051aa7.JPGbalancers2.thumb.JPG.b282a1e4cde381d3405d7aec9c595757.JPGbalancers1.thumb.JPG.1007cf6b0d5245de9e1e809ec5383b4b.JPGDPUI.thumb.JPG.e517d9502e22406a6ca45fbf1195f0b1.JPG

Share this post


Link to post
Share on other sites
  • 0

Unfortunately, I believe that this is normal, in this case, and that you won't see the ratio reduced, because it is "correct".  

But that's fine. As long as it's doing what you want, then this should be okay. 

 

However, you do need do disable the "Prevent Drive Overfill" and the "Disk Space Equalizer" balancers,  The second one especially. As this may be why it's having issues. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×