Jump to content
Covecube Inc.
  • 0
Randomified

"File System Damaged" on server's OS drive

Question

I'm in the middle of trialing DrivePool/Scanner, and the latter is giving me a problem that sounds AWFULLY similar to this one:
http://community.covecube.com/index.php?/topic/1172-file-system-damaged/
No matter what I do, or how many times I run ChkDsk, I get "File System Damaged" for my C: drive within Scanner.

Running Scanner ver. 2.5.1.3062
on Windows Server 2008 R2

I try to do a ChkDsk (scheduled for reboot) with /F /V /R /B, which to my understanding is just about as thorough as can be for an NTFS drive.

Running ChkDsk in a command-prompt, no flags, gives this warning: "The volume is in use by another process. Chkdsk might report errors when no corruption is present."
One of the errors I'm frequently seeing in such a situation is "The Volume Bitmap is incorrect."  Yet when I try to do a thorough check/repair at reboot, Windows says there is no problem!

Like the above forum post, I had removed drive letters for my DrivePool drives and instead mounted them to
C:\DrivePool HDs\Drive0
C:\DrivePool HDs\Drive1
etc.

Taking a pointer from that poster, I tried unmounting and re-mounting, then ChkDsk /F during reboot, to no avail.  Then I tried unmounting, ChkDsk /F /V /R /B at reboot, and Scanner STILL flags a problem when I tell it to scan (with DrivePool drives still unmounted).

* Edit * Immediately after that last attempt, I went in and re-enabled verbose logging for ChkDsk, in advanced options, since that setting clears at reboot.  Then I had Scanner re-scan to make sure the log file had more info.  This time it PASSED, even though the two attempts were only minutes apart, with the 'verbose' setting being the ONLY change.  What?!  Trying to repeat my good fortune a second time showed File System Damaged again, though.

 

I will submit log files through the Contact page, but wanted to keep the discussion (mostly) public in case this helps someone else in the future.

There was no conclusion posted for that conversation; has some solution been found?  If not, could we get an option to exclude only specified drives from File System checking?

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Earlier I had found this site through Googling:

http://www.hvsent.com/chkdsk-is-not-fixing-the-errors/

 

But it's just disconcerting if a tool that's supposed to be monitoring drives is constantly telling you that one of yours has a problem!

And I assume that many/most Scanner users don't have this problem with their OS drive, as I haven't seen any warning or disclaimer about it from StableBit, nor does it seem like a strongly prevalent question in the forums.

Share this post


Link to post
Share on other sites
  • 0

Please download the latest beta versions:

http://dl.covecube.com/ScannerWindows/beta/download/StableBit.Scanner_2.5.2.3100_BETA.exe

http://dl.covecube.com/DrivePoolWindows/beta/download/StableBit.DrivePool_2.2.0.625_x64_BETA.exe

 

This should fix the issue you're seeing. 

 

 

If it doesn't, then let us know.

Share this post


Link to post
Share on other sites
  • 0

Amazing response time, thanks!  :-) 

Installed, and it's checking now.

One question--after reboot, the updated Scanner said that none of the drives have been checked at all before, so it apparently lost its old scanning info.  Does/will that always happen after installing an update?

Share this post


Link to post
Share on other sites
  • 0

I saw your message about

 

 

if that doesn't help, could you open an elevated command prompt, and run the following command:
"Vssadmin list shadowstorage > vss.txt"
 
And then upload the vss.txt file here (it should located in "C:\Windows\System32\", most likely). 
 
 
The previous ticket, the "VSS" storage was on the pool, which was causing issues, as well, as an issue with the pool partitioning.

 

I did again get the File System Damaged message after the OS drive finished scanning.

After following your instructions, this is the output:

 

"vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
© Copyright 2001-2005 Microsoft Corp.

No items found that satisfy the query."

 

Was that an expected result?  I got the same response running that command on two other servers, as well.

Share this post


Link to post
Share on other sites
  • 0

All three servers that I'm currently trying to set up gave precisely the same response as before, "No items found that satisfy the query." 

 

It's possible I made some mistake in setting up the servers, but I just perused 'Features' that Windows Server offers to install, and didn't see any option about VSS that I might have skipped before...  I'll try to Google that message.

Share this post


Link to post
Share on other sites
  • 0

In the other post about someone having a similar problem, they mentioned "There appears system log VSS error every time I run Scanner recheck."  I went and looked at the System Event Log, and did find the following:

 

The shadow copy of volume \\?\Volume{...} could not be created because volume E:, which is specified as the location for shadow copy storage, is not an NTFS volume or an error was encountered while trying to determine the file system type of this volume.

 

A log like that, or similar, happened 6 times overnight.  It sounds possibly more in line with what you're expecting, though I have no idea why the total discrepancy with the Vssadmin message. 

 

I recall reading, somewhere in my forum search here, about someone needing to tweak an advanced setting so DrivePool reported NTFS instead of CoveFS to the operating system.  I almost attempted to find that again and give it a try, but decided to play it safe and wait for a response instead.  ;-)

 

* Edit * Ah, re-found that NTFS option:
http://wiki.covecube.com/StableBit_DrivePool_Advanced_Settings

via this thread:

http://community.covecube.com/index.php?/topic/861-mac-file-too-large-for-the-volumes-format/

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...