Jump to content

  • Log in with Twitter Log in with Windows Live Log In with Google      Sign In   
  • Create Account

Photo

SSD Optimizer and Placement Rules Frustrations

ssd optimizer file placement rules

  • Please log in to reply
5 replies to this topic

#1 MatthewW

MatthewW

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 02 April 2017 - 08:10 PM

There are a lot of SSD Optimizer threads, and I've thread through most of them.  I'm still having frustrations, so here's a thread of my own.

 

My Setup

 

For some context, my previous setup was:

 

- DrivePool for download/scratch space, with SSD Optimizer active

- Final copy of files live on network share outside of pool

 

This was fine!  But space was running out on the NAS.  In order to easily spill into the scratch space, I now:

 

- Mount NAS storage via iSCSI (so local drive letter)

- Merge these into DrivePool drive

- Apply file placement rules so "D:\Plex" only lives on these iSCSI mounts

 

SSD Optimizer and File Rules Failure

 

This is where I have been totally unable to find a solution where the SSD Optimizer will play sensibly.

 

I just moved to 2.4.0.740 in the hopes it would help.  I see the same behavior as before.  My setup is:

 

Balancers:

Screenshot 2017-04-02 12.56.51.png

 

This setup actually works, as long as I have no placement rules.  But I want the media folder to only live on the network ("Vault") disks, so the simplest setup is editing the folder, which makes this rule:

 

Screenshot 2017-04-02 12.58.17.png

 

Immediately I have two problems:

 

1) Pool Organization freaks out.  This makes no sense, because I've verified that the Vault are indeed storing the right content:

 

Screenshot 2017-04-02 12.52.26.png

 

Screenshot 2017-04-02 13.01.00.png

 

2) The SSD Optimizer is no longer covering "D:\Plex".  I can verify this by copying large files there from somewhere else and watching Disk Performance in the StableBit DrivePool window.

 

Adding SSDs to Placement Rules

 

So, my next step is to think "well, maybe I should include the SSDs in the placement rule".  

 

This re-enables SSD Optimizer coverage of the drives, except that balancing now begins to move content onto the drives.  Worse, it seems emptying one full SSD just spills over onto the others.

 

I have tried various combinations of the placement settings, to no avail.  It either complete turns off SSD Optimizer coverage of the path, or turns it on and begins to permanently store content on the SSDs.

 

Screenshot 2017-04-02 13.04.34.png

 

Final Thoughts

 

I did perform a full "reset all settings" and reboot after moving to the beta.

 

All I want is:

 

- SSD Optimizer coverage of the entire pool

- When moving from SSD -> Archive disks, respect the file placement rules

 

And I haven't found a way to do this.  Help?

 

(Also, yes, I should absolutely move to mount points instead of disk letters--didn't quite expect the drive count to get this high when I started with this setup).



#2 Spider99

Spider99

    Advanced Member

  • Members
  • PipPipPip
  • 442 posts
  • LocationWarrington, UK

Posted 02 April 2017 - 10:00 PM

have you got "File placement rules respect...." checked?

 

If so uncheck it and see if that improves things


Tim

---------

DrivePool & Scanner on 2012R2 Essentials Server Gigabyte Z87x OC Force, i7-4790S, 32 GB, LSI 9211, HP SAS Expander, 27 Storage disks, 6 SSD Cache, ~115 TB Storage


#3 MatthewW

MatthewW

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 02 April 2017 - 11:48 PM

I have, to no avail.  My experiments can be summed up with:

 

- The only way I've found for SSD Optimizer to cover a folder is to either have no placement rules set, or to include the SSD drives in the placement rules.

 

- But, if I include the SSD drives in the placement rules, I haven't found a way to stop the balancer from permanently storing files there too.



#4 Christopher (Drashna)

Christopher (Drashna)

    Customer and Technical Support

  • Administrators
  • 8,196 posts
  • LocationSan Diego, CA, USA

Posted 10 April 2017 - 06:44 AM

Uncheck "unless drives are being emptied".

 

Also, make sure you select the SSD drives for the file placement rules.


Christopher Courtney

aka "Drashna"

Microsoft MVP for Windows Home Server 2009-2012

Lead Moderator for We Got Served

Moderator for Home Server Show

 

This is my server

 

Lots of "Other" data on your pool? Read about what it is here.


#5 MatthewW

MatthewW

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 14 April 2017 - 03:01 AM

Unchecking "unless drives are being emptied" didn't help, I tried that initially.

 

The SSD Optimizer is great, but it's pretty clear it needs to operate as a 1st-class feature in order to really work in more advanced scenarios.  As near as I can tell, the isn't any real difference between "file being created" and "file being balanced" rules, which is what I really need.

 

P.S.  Adding the SSDs to the file placement rules just results in one SSD emptying to another SSD endlessly, without the files permanently moving to the archive drives.



#6 MatthewW

MatthewW

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 17 April 2017 - 01:26 AM

As a conclusion here, I just ended up breaking off the Vault disks into their own pool (used de-seeding, new pool, re-seeding, was just a few minutes of work).

 

I lose a tiny bit of space overflow flexibility, I guess, but much easier to manage both pool separately without rules clashing everywhere...







Also tagged with one or more of these keywords: ssd optimizer, file placement rules

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users