Jump to content

  • Log in with Twitter Log in with Windows Live Log In with Google      Sign In   
  • Create Account

Photo

SSD Optimizer problem


Best Answer Christopher (Drashna) , 02 April 2016 - 08:42 AM

This is part of the problem with the way that the SSD optimizer balancer works. 

 

Specifically, it creates "real  time placement limiters" to limit what disks new files can be placed on.  

 

 

 

I'm guessing that the SSD is below the threshold set for it (75% by default, so ~45-50GBs).  Increasing the limit on the SSD may help this (but lowering it may as well, but this would force the pool to place files on the other drives rather than on the SSD). 

 

 

Additionally, there are some configuration changes that may help make the software more aggressively move data off of the drive.

http://stablebit.com...ancing Settings

On the main balancing settings page, set it to "Balance immediately", and uncheck the "No more often than ever X hours" option, it set it to a low number like 1-2 hours. 

 

For the balancing ratio slider, set this to "100%", and check the "or if at least this much data needs to be moved" and set it to a very low number (like 5GBs). 

 

This should cause the balancing engine to rather aggressively move data out of the SSD drive and onto the archive drives, reducing the likelihood that this will happen.

 

 

Also, it may not be a bad idea to use a larger sized SSD, as the free space on the drive is what gets reported when adding new files. 


This is part of the problem with the way that the SSD optimizer balancer works. 

 

Specifically, it creates "real  time placement limiters" to limit what disks new files can be placed on.  

 

 

 

I'm guessing that the SSD is below the threshold set for it (75% by default, so ~45-50GBs).  Increasing the limit on the SSD may help this (but lowering it may as well, but this would force the pool to place files on the other drives rather than on the SSD). 

 

 

Additionally, there are some configuration changes that may help make the software more aggressively move data off of the drive.

http://stablebit.com...ancing Settings

On the main balancing settings page, set it to "Balance immediately", and uncheck the "No more often than ever X hours" option, it set it to a low number like 1-2 hours. 

 

For the balancing ratio slider, set this to "100%", and check the "or if at least this much data needs to be moved" and set it to a very low number (like 5GBs). 

 

This should cause the balancing engine to rather aggressively move data out of the SSD drive and onto the archive drives, reducing the likelihood that this will happen.

 

 

Also, it may not be a bad idea to use a larger sized SSD, as the free space on the drive is what gets reported when adding new files. 

Go to the full post


  • Please log in to reply
4 replies to this topic

#1 plebann

plebann

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 31 March 2016 - 09:33 AM

Hi.

I'm using DrivePool with SSD Optimizer plugin (with option Fill ssd drives up to 90%).

I have dedicated partition on my ssd (small, 70GB), SSD Optimizer plugin configured and worked as expected till now.

 

Free space on SSD Partition - 22GB.

Trying to copy one file 43GB to DrivePool Pool (with have 2TB free space) and give error "Not enough free space".

I'm assuming that SSD Optimizer plugin is trying to put new file on my SSD disk, but this file is larger that free space on that disk but - there is still more than 10% free space on that disk and plugin is forcing to place new file on sdd partition.

 

I suppose i'm right because when i disabled SSD Optimizer plugin i was able to copy that file no problem.

 

Is this real issue or i need to improve my SSD Optimizer settings?


  • MikrotikOl likes this

#2 Christopher (Drashna)

Christopher (Drashna)

    Customer and Technical Support

  • Administrators
  • 8,203 posts
  • LocationSan Diego, CA, USA

Posted 02 April 2016 - 08:42 AM   Best Answer

This is part of the problem with the way that the SSD optimizer balancer works. 

 

Specifically, it creates "real  time placement limiters" to limit what disks new files can be placed on.  

 

 

 

I'm guessing that the SSD is below the threshold set for it (75% by default, so ~45-50GBs).  Increasing the limit on the SSD may help this (but lowering it may as well, but this would force the pool to place files on the other drives rather than on the SSD). 

 

 

Additionally, there are some configuration changes that may help make the software more aggressively move data off of the drive.

http://stablebit.com...ancing Settings

On the main balancing settings page, set it to "Balance immediately", and uncheck the "No more often than ever X hours" option, it set it to a low number like 1-2 hours. 

 

For the balancing ratio slider, set this to "100%", and check the "or if at least this much data needs to be moved" and set it to a very low number (like 5GBs). 

 

This should cause the balancing engine to rather aggressively move data out of the SSD drive and onto the archive drives, reducing the likelihood that this will happen.

 

 

Also, it may not be a bad idea to use a larger sized SSD, as the free space on the drive is what gets reported when adding new files. 


This is part of the problem with the way that the SSD optimizer balancer works. 

 

Specifically, it creates "real  time placement limiters" to limit what disks new files can be placed on.  

 

 

 

I'm guessing that the SSD is below the threshold set for it (75% by default, so ~45-50GBs).  Increasing the limit on the SSD may help this (but lowering it may as well, but this would force the pool to place files on the other drives rather than on the SSD). 

 

 

Additionally, there are some configuration changes that may help make the software more aggressively move data off of the drive.

http://stablebit.com...ancing Settings

On the main balancing settings page, set it to "Balance immediately", and uncheck the "No more often than ever X hours" option, it set it to a low number like 1-2 hours. 

 

For the balancing ratio slider, set this to "100%", and check the "or if at least this much data needs to be moved" and set it to a very low number (like 5GBs). 

 

This should cause the balancing engine to rather aggressively move data out of the SSD drive and onto the archive drives, reducing the likelihood that this will happen.

 

 

Also, it may not be a bad idea to use a larger sized SSD, as the free space on the drive is what gets reported when adding new files. 


Christopher Courtney

aka "Drashna"

Microsoft MVP for Windows Home Server 2009-2012

Lead Moderator for We Got Served

Moderator for Home Server Show

 

This is my server

 

Lots of "Other" data on your pool? Read about what it is here.


#3 plebann

plebann

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 04 April 2016 - 07:31 AM

Thank You for this satisfying answer.



#4 Christopher (Drashna)

Christopher (Drashna)

    Customer and Technical Support

  • Administrators
  • 8,203 posts
  • LocationSan Diego, CA, USA

Posted 05 April 2016 - 08:28 PM

You are very welcome!

 

And I'm pinning the topic, as it does come up often enough, that a pinned thread about it may help others in the future. 


Christopher Courtney

aka "Drashna"

Microsoft MVP for Windows Home Server 2009-2012

Lead Moderator for We Got Served

Moderator for Home Server Show

 

This is my server

 

Lots of "Other" data on your pool? Read about what it is here.


#5 duelistjp

duelistjp

    Member

  • Members
  • PipPip
  • 28 posts

Posted 23 July 2017 - 11:24 PM

yeah this made this feature a bit less useful to me that it can't somehow know the size of the file before it writes.  i sometimes have files larger than the spare 32gb ssd i had lying around.  but i can see why you wouldn't always be able to tell the size before you start.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users