Jump to content
Covecube Inc.
  • Announcements

    • Christopher (Drashna)

      Login issues   11/07/17

      If you have issues with logging in, make sure you use your display name and not the "username" or email.  Or head here for more info.   http://community.covecube.com/index.php?/topic/3252-login-issues/  
    • Christopher (Drashna)

      Getting Help   11/07/17

      If you're experiencing problems with the software, the best way to get ahold of us is to head to https://stablebit.com/Contact, especially if this is a licensing issue.    Issues submitted there are checked first, and handled more aggressively. So, especially if the problem is urgent, please head over there first. 
  • 0
Tupper7

SSD Optimizer Drive Placement

Question

Hello,

I have been using DrivePool for a while and it has been working great. Recently I started using the SSD Optimizer plugin.  It is also working great except when it comes to file placement on drives.  All the files I copy to the drivepool appear to be copying to only one disk now instead of whichever disk has the most free space.  Is there something that needs to be done in order for this to work correctly again? Thanks.

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Thanks, but that does not solve the problem.  I want all files to go to the SSD cache drive.  Right now files from the SSD cache are being automatically balanced to only 1 disk, instead of spreading them out across multiple.

Share this post


Link to post
Share on other sites
  • 0

Tupper, 

 

What are you try to accomplish specifically?

 

Do you want the files on the cloud drive and to remain there? 

If so, then you want to disable the "Unless a drive is being emptied" option, rather than the "File placement rules respect real-time file placement limits set by the balancing plug-ins" 

 

 

 

Otherwise, are you using duplication? And if so, how many SSD drives do you have (as marked by the balancer).

 

 

I've updated this topic to reflect well, more behavior, and have moved it into the "Nuts and Bolts" section, as it is more fitting there, I think. 

Share this post


Link to post
Share on other sites
  • 0

I am trying to get the SSD Cache drive to move files to the Archive Drive with the most free space.

 

I have 1 SSD and no duplication.

 

Currently the files move from the SSD Cache to only the top drive listed in "Drives" under the SSD Optimizer.

Ordered Placement is not checked.

post-2375-0-14071500-1456946404_thumb.png

post-2375-0-58290000-1456946404_thumb.png

Share this post


Link to post
Share on other sites
  • 0

It should automatically move the data to the drive with the most available (absolute, not percentage).

 

 

If it's still not balancing properly (eg, there are other drives with more free space), then enable logging and reproduce the issue:

http://wiki.covecube.com/StableBit_DrivePool_2.x_Log_Collection

Share this post


Link to post
Share on other sites
  • 0

Just because I want to be explicitly clear:

 

It does write to the SSD drive fine. But when moving files to the archive drives, it seems to be moving files to one disk at a time, rather than spreading them out. 

 

And you are NOT using file placement rules. 

 

 

Correct? 

 

 

If that's correct, check two things:

  • Are these drives all the same size? 
    Or are some larger than others? 
    • If some of the drives are larger than the others, then this is absolutely normal, as files are placed on the disk with the most absolute free space available, not the highest percentage of free space. 
      Meaning if you have a 3TB, 4TB and 5TB drive, it will fill the 5TB first, with ~1TB of data. Then it will start filling the 4TB and 5TB until the 4TB is 1TB full and the 5TB is 2TBs full, and then it will start filling all three drives. 
      This may be what you're seeing, and if it is, it's normal. 
  • Check to see if any other balancers are in use. If there are, this can cause issues, as the SSD Optimizer balancer is highly specialized and could conflict with other balancers. 

 

Regardless, I've already flagged the issue for Alex (the developer), to see if he can see what is going on here. 

 

https://stablebit.com/Admin/IssueAnalysis/25942

Share this post


Link to post
Share on other sites
  • 0

Just because I want to be explicitly clear:

 

It does write to the SSD drive fine. But when moving files to the archive drives, it seems to be moving files to one disk at a time, rather than spreading them out. 

 

And you are NOT using file placement rules. 

 

 

Correct? 

 

 

If that's correct, check two things:

  • Are these drives all the same size? 

    Or are some larger than others?

    • If some of the drives are larger than the others, then this is absolutely normal, as files are placed on the disk with the most absolute free space available, not the highest percentage of free space. 

      Meaning if you have a 3TB, 4TB and 5TB drive, it will fill the 5TB first, with ~1TB of data. Then it will start filling the 4TB and 5TB until the 4TB is 1TB full and the 5TB is 2TBs full, and then it will start filling all three drives. 

      This may be what you're seeing, and if it is, it's normal. 

  • Check to see if any other balancers are in use. If there are, this can cause issues, as the SSD Optimizer balancer is highly specialized and could conflict with other balancers. 

 

Regardless, I've already flagged the issue for Alex (the developer), to see if he can see what is going on here. 

 

https://stablebit.com/Admin/IssueAnalysis/25942

 

 

Yes, that is Correct.

 

1) All the drives are the same size

2) No other balancers are in use

Share this post


Link to post
Share on other sites
  • 0

I am trying to get the SSD Cache drive to move files to the Archive Drive with the most free space.

 

I have 1 SSD and no duplication.

 

Currently the files move from the SSD Cache to only the top drive listed in "Drives" under the SSD Optimizer.

Ordered Placement is not checked.

 

This describes my issue exactly.

 

I have no duplicated files, nor is duplication enabled at any level of the drivepool.  I have a single SSD I want to use as a landing zone.

 

I have the SSD Optimzer plugin installed.

SSD Optimizer is the only plugin enabled.

 

I have 8 archive drives.  They are all the same size (and until I used the SSD Optimizer, they all had equal usage).

I have 1 SSD.   The SSD and archive drives are configured as such in the SSD Optimizer plugin.

 

I have no file placement rules.  I have no issues with WHEN the balancing is triggered.  It kicks off the balancing perfectly fine.

 

My issue is, when it balances the files off the SSD, it puts all the files on 1 drive.  This drive happens to be the 'first drive' listed at the top of the SSD balancer plugin (where you check the boxes for SSD or Archive).

I do not have ordered placement checked at the bottom (on either the unduplicated or duplicated tabs). 

https://www.dropbox.com/s/532rpvhw10wfp8q/ssd-settings.PNG

 

Here is the main screen:

https://www.dropbox.com/s/mz3yirit9jl7err/drivepool.PNG

 

Usage was even until the SSD optimizer, and now it's clearly only placing data on DRPL07 during balancing. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×